Remi's RPM repository - Packages

Blog | Forum | Repository | Wizard

php-phpmyadmin-sql-parser5 - A validating SQL lexer and parser with a focus on MySQL dialect

Website:
https://github.com/phpmyadmin/sql-parser
Licence:
GPLv2+
Vendor:
Remi's RPM repository <https://rpms.remirepo.net/>
Description:
A validating SQL lexer and parser with a focus on MySQL dialect.

This library was originally developed for phpMyAdmin during
the Google Summer of Code 2015.

Autoloader: /usr/share/php/PhpMyAdmin/SqlParser5/autoload.php

Packages

php-phpmyadmin-sql-parser5-5.4.1-1.remi.src [365 KiB] Changelog by Remi Collet (2020-10-16):
- update to 5.4.1
php-phpmyadmin-sql-parser5-5.4.0-1.remi.src [369 KiB] Changelog by Remi Collet (2020-10-09):
- update to 5.4.0
- switch to phpunit9
php-phpmyadmin-sql-parser5-5.3.1-1.remi.src [349 KiB] Changelog by Remi Collet (2020-03-21):
- update to 5.3.1
php-phpmyadmin-sql-parser5-5.2.0-1.remi.src [330 KiB] Changelog by Remi Collet (2020-01-08):
- update to 5.2.0
php-phpmyadmin-sql-parser5-5.1.0-1.remi.src [326 KiB] Changelog by Remi Collet (2019-11-12):
- update to 5.1.0
- drop patch merged upstream
- use phpunit8
php-phpmyadmin-sql-parser5-5.0.0-1.remi.src [325 KiB] Changelog by Remi Collet (2019-09-02):
- update to 5.0.0
- rename to php-phpmyadmin-sql-parser5
- move to /usr/share/php/PhpMyAdmin/SqlParser5
- raise dependency on PHP 7.1
- switch to phpunit7
- add patch for PHP 7.4 from
  https://github.com/phpmyadmin/sql-parser/pull/258