Remi's RPM repository - Packages

Blog | Forum | Repository | Wizard

php-jeremeamia-superclosure - Serialize Closure objects, including their context and binding

Website:
https://github.com/jeremeamia/super_closure
Licence:
MIT
Vendor:
Remi Collet
Description:
Even though serializing closures is "not allowed" by PHP,
the SuperClosure library makes it possible

To use this library, you just have to add, in your project:
  require-once '/usr/share/php/SuperClosure/autoload.php';

Packages

php-jeremeamia-superclosure-2.4.0-1.remi.src [29 KiB] Changelog by Remi Collet (2018-03-22):
- update to 2.4.0
- use range dependencies on F28+ else package names
- allow nikic/php-parser v4 (not yet available)
php-jeremeamia-superclosure-2.3.0-1.remi.src [29 KiB] Changelog by Remi Collet (2016-12-07):
- update to 2.3.0
- switch to fedora/autoloader
- allow nikic/php-parser v3
php-jeremeamia-superclosure-2.2.0-3.remi.src [28 KiB] Changelog by Remi Collet (2016-05-21):
- use nikic/php-parser v2 when available
php-jeremeamia-superclosure-2.2.0-1.remi.src [28 KiB] Changelog by Remi Collet (2015-12-06):
- update to 2.2.0
- run test suite with both php 5 and 7 when available
- add dependency on symfony/polyfill-php56
php-jeremeamia-superclosure-2.1.0-1.remi.src [27 KiB] Changelog by Remi Collet (2015-09-01):
- initial package