Remi's RPM repository - Packages

Blog | Forum | Repository | Wizard

php-deepend-Mockery - Mockery is a simple but flexible PHP mock object framework

Website:
https://github.com/padraic/mockery
Licence:
BSD
Vendor:
Remi Collet
Description:
Mockery is a simple but flexible PHP mock object framework for use in unit
testing. It is inspired by Ruby's flexmock and Java's Mockito, borrowing
elements from both of their APIs.

To use this library, you just have to add, in your project:
  require_once '/usr/share/php/Mockery/autoload.php';

Packages

php-deepend-Mockery-0.9.9-7.remi.src [105 KiB] Changelog by Remi Collet (2018-09-10):
- use range dependencies
- ensure hamcrest v1 is used, fix FTBFS
php-deepend-Mockery-0.9.9-4.remi.src [105 KiB] Changelog by Remi Collet (2017-10-06):
- add patches for PHP 7.2
php-deepend-Mockery-0.9.9-1.remi.src [102 KiB] Changelog by Remi Collet (2017-02-28):
- Update to 0.9.9
php-deepend-Mockery-0.9.8-1.remi.src [102 KiB] Changelog by Remi Collet (2017-02-10):
- Update to 0.9.8
php-deepend-Mockery-0.9.7-1.remi.src [101 KiB] Changelog by Remi Collet (2016-12-23):
- Update to 0.9.7