Remi's RPM repository - Packages

Blog | Forum | Repository | Wizard

php-bartlett-PHP-CompatInfo - Find out version and the extensions required for a piece of code to run

Website:
http://php5.laurent-laville.org/compatinfo/
Licence:
BSD
Vendor:
Remi Collet
Description:
PHP_CompatInfo will parse a file/folder/array to find out the minimum
version and extensions required for it to run. CLI version has many reports
(extension, interface, class, function, constant) to display and ability to
show content of dictionary references.

Documentation: http://php5.laurent-laville.org/compatinfo/manual/current/en/

Packages

php-bartlett-PHP-CompatInfo-5.1.0-1.remi.src [408 KiB] Changelog by Remi Collet (2018-11-28):
- update to 5.1.0
- raise dependency on bartlett/php-reflect 4.3
- add explicit dependency on nikic/php-parser
- add explicit dependency on doctrine/cache
- add dependency on psr/log
- switch to phpunit7
php-bartlett-PHP-CompatInfo-5.0.12-1.remi.src [422 KiB] Changelog by Remi Collet (2018-02-02):
- Update to 5.0.12 (no change)
- use range dependency on F27+
php-bartlett-PHP-CompatInfo-5.0.11-1.remi.src [422 KiB] Changelog by Remi Collet (2017-12-12):
- Update to 5.0.11 (no change)
- raise dependency on PHP 5.5
php-bartlett-PHP-CompatInfo-5.0.10-1.remi.src [421 KiB] Changelog by Remi Collet (2017-12-12):
- Update to 5.0.10 (no change)
- raise dependency on bartlett/php-reflect 4.2
- only require a single Symfony version
php-bartlett-PHP-CompatInfo-5.0.9-1.remi.src [420 KiB] Changelog by Remi Collet (2017-12-06):
- Update to 5.0.9