From 786d8944169e5c7f5508f14eb9a223ec13ba2248 Mon Sep 17 00:00:00 2001
From: Remi Collet <fedora@famillecollet.com>
Date: Sat, 30 Jul 2016 20:04:57 +0200
Subject: zephir-parser: cleanup

---
 zephir-parser.spec | 43 +++++++++++++++++++++----------------------
 zephir-rpm.patch   |  4 ++--
 2 files changed, 23 insertions(+), 24 deletions(-)

diff --git a/zephir-parser.spec b/zephir-parser.spec
index f2342bb..148d96c 100644
--- a/zephir-parser.spec
+++ b/zephir-parser.spec
@@ -25,7 +25,7 @@
 
 Name:           %{?scl_prefix}%{gh_project}-parser
 Version:        0.9.3
-Release:        1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
+Release:        1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
 Summary:        Zephir parser extension
 
 Group:          Development/Libraries
@@ -66,27 +66,6 @@ Group:         Development/Languages
 BuildArch:     noarch
 %endif
 
-%description  -n %{?scl_prefix}%{gh_project}
-Zephir - Ze(nd Engine) Ph(p) I(nt)r(mediate) - is a high level language
-that eases the creation and maintainability of extensions for PHP. 
-Zephir extensions are exported to C code that can be compiled and
-optimized by major C compilers such as gcc/clang/vc++. Functionality
-is exposed to the PHP language.
-
-Main features:
-* Both dynamic/static typing
-* Reduced execution overhead compared with full interpretation
-* Restricted procedural programming, promoting OOP
-* Memory safety
-* Ahead-of-time (AOT) compiler to provide predictable performance
-
-Compiler design goals:
-* Multi-pass compilation
-* Type speculation/inference
-* Allow runtime profile-guided optimizations, pseudo-constant propagation
-  and indirect/virtual function inlining
-
-
 Requires:       %{?scl_prefix}php-cli
 Requires:       %{name} = %{version}-%{release}
 # From composer.json, "require"
@@ -109,6 +88,26 @@ Requires:       %{?scl_prefix}php-xml
 
 Provides:       %{?scl_prefix}php-composer(%{gh_owner}/%{gh_project}) = %{version}
 
+%description  -n %{?scl_prefix}%{gh_project}
+Zephir - Ze(nd Engine) Ph(p) I(nt)r(mediate) - is a high level language
+that eases the creation and maintainability of extensions for PHP.
+Zephir extensions are exported to C code that can be compiled and
+optimized by major C compilers such as gcc/clang/vc++. Functionality
+is exposed to the PHP language.
+
+Main features:
+* Both dynamic/static typing
+* Reduced execution overhead compared with full interpretation
+* Restricted procedural programming, promoting OOP
+* Memory safety
+* Ahead-of-time (AOT) compiler to provide predictable performance
+
+Compiler design goals:
+* Multi-pass compilation
+* Type speculation/inference
+* Allow runtime profile-guided optimizations, pseudo-constant propagation
+  and indirect/virtual function inlining
+
 
 %prep
 %setup -q -n %{gh_project}-%{gh_commit}
diff --git a/zephir-rpm.patch b/zephir-rpm.patch
index dc497e4..505e682 100644
--- a/zephir-rpm.patch
+++ b/zephir-rpm.patch
@@ -26,9 +26,9 @@ diff -up bin/zephir.rpm bin/zephir
  
  if [[ $1 && $2 && $3 && "$1"=="-c" ]]; then
 -    php -d safe_mode=Off -d enable_dl=On -c $2 $ZEPHIRDIR/compiler.php ${*:3}
-+    @BINDIR@/php -d extension=zephir_parser.so -c $2 $ZEPHIRDIR/compiler.php ${*:3}
++    @BINDIR@/php -d memory_limit=1G -d extension=zephir_parser.so -c $2 $ZEPHIRDIR/compiler.php ${*:3}
  else
 -    php -d safe_mode=Off -d enable_dl=On $ZEPHIRDIR/compiler.php $*
-+    @BINDIR@/php -d extension=zephir_parser.so $ZEPHIRDIR/compiler.php $*
++    @BINDIR@/php -d memory_limit=1G -d extension=zephir_parser.so $ZEPHIRDIR/compiler.php $*
  fi
  
-- 
cgit