From 9ebae8c4b7d6e3a1f9b2101c2fc1c498637b1a8d Mon Sep 17 00:00:00 2001
From: Remi Collet <remi@remirepo.net>
Date: Tue, 8 Jun 2021 14:47:07 +0200
Subject: cleanup / reorder

---
 php-8.1.0-systzdata-v20.patch | 12 ++++++------
 php-8.1.0-timelib.patch       |  4 ++--
 php.spec                      |  8 ++++----
 3 files changed, 12 insertions(+), 12 deletions(-)

diff --git a/php-8.1.0-systzdata-v20.patch b/php-8.1.0-systzdata-v20.patch
index a2e3827..155cdac 100644
--- a/php-8.1.0-systzdata-v20.patch
+++ b/php-8.1.0-systzdata-v20.patch
@@ -92,7 +92,7 @@ diff -up php-8.0.0beta3/ext/date/lib/parse_tz.c.systzdata php-8.0.0beta3/ext/dat
  	/* read ID */
  	version = (*tzf)[3] - '0';
  	*tzf += 4;
-@@ -566,7 +584,429 @@ void timelib_dump_tzinfo(timelib_tzinfo
+@@ -577,7 +595,429 @@ void timelib_dump_tzinfo(timelib_tzinfo
  	}
  }
  
@@ -523,7 +523,7 @@ diff -up php-8.0.0beta3/ext/date/lib/parse_tz.c.systzdata php-8.0.0beta3/ext/dat
  {
  	int left = 0, right = tzdb->index_size - 1;
  
-@@ -592,9 +1032,48 @@ static int seek_to_tz_position(const uns
+@@ -603,9 +1043,48 @@ static int seek_to_tz_position(const uns
  	return 0;
  }
  
@@ -572,7 +572,7 @@ diff -up php-8.0.0beta3/ext/date/lib/parse_tz.c.systzdata php-8.0.0beta3/ext/dat
  }
  
  const timelib_tzdb_index_entry *timelib_timezone_identifiers_list(const timelib_tzdb *tzdb, int *count)
-@@ -606,7 +1085,30 @@ const timelib_tzdb_index_entry *timelib_
+@@ -617,7 +1096,30 @@ const timelib_tzdb_index_entry *timelib_
  int timelib_timezone_id_is_valid(const char *timezone, const timelib_tzdb *tzdb)
  {
  	const unsigned char *tzf;
@@ -604,7 +604,7 @@ diff -up php-8.0.0beta3/ext/date/lib/parse_tz.c.systzdata php-8.0.0beta3/ext/dat
  }
  
  static int skip_64bit_preamble(const unsigned char **tzf, timelib_tzinfo *tz)
-@@ -651,6 +1153,8 @@ static timelib_tzinfo* timelib_tzinfo_ct
+@@ -662,6 +1164,8 @@ static timelib_tzinfo* timelib_tzinfo_ct
  timelib_tzinfo *timelib_parse_tzfile(const char *timezone, const timelib_tzdb *tzdb, int *error_code)
  {
  	const unsigned char *tzf;
@@ -613,7 +613,7 @@ diff -up php-8.0.0beta3/ext/date/lib/parse_tz.c.systzdata php-8.0.0beta3/ext/dat
  	timelib_tzinfo *tmp;
  	int version;
  	int transitions_result, types_result;
-@@ -658,7 +1162,7 @@ timelib_tzinfo *timelib_parse_tzfile(con
+@@ -669,7 +1173,7 @@ timelib_tzinfo *timelib_parse_tzfile(con
  
  	*error_code = TIMELIB_ERROR_NO_ERROR;
  
@@ -622,7 +622,7 @@ diff -up php-8.0.0beta3/ext/date/lib/parse_tz.c.systzdata php-8.0.0beta3/ext/dat
  		tmp = timelib_tzinfo_ctor(timezone);
  
  		version = read_preamble(&tzf, tmp, &type);
-@@ -699,11 +1203,36 @@ timelib_tzinfo *timelib_parse_tzfile(con
+@@ -712,11 +1216,36 @@ timelib_tzinfo *timelib_parse_tzfile(con
  			return NULL;
  		}
  
diff --git a/php-8.1.0-timelib.patch b/php-8.1.0-timelib.patch
index 2512829..269f1d0 100644
--- a/php-8.1.0-timelib.patch
+++ b/php-8.1.0-timelib.patch
@@ -82,7 +82,7 @@ diff --git a/ext/date/lib/timelib.h b/ext/date/lib/timelib.h
 index 7073c6c..8e82e58 100644
 --- a/ext/date/lib/timelib.h
 +++ b/ext/date/lib/timelib.h
-@@ -375,7 +375,8 @@ typedef struct _timelib_tzdb {
+@@ -370,7 +370,8 @@ typedef struct _timelib_tzdb {
  #define TIMELIB_UNSET   -99999
  
  /* An entry for each of these error codes is also in the
@@ -92,7 +92,7 @@ index 7073c6c..8e82e58 100644
  #define TIMELIB_ERROR_NO_ERROR                            0x00
  #define TIMELIB_ERROR_CANNOT_ALLOCATE                     0x01
  #define TIMELIB_ERROR_CORRUPT_TRANSITIONS_DONT_INCREASE   0x02
-@@ -383,8 +384,9 @@ typedef struct _timelib_tzdb {
+@@ -378,8 +379,9 @@ typedef struct _timelib_tzdb {
  #define TIMELIB_ERROR_CORRUPT_NO_ABBREVIATION             0x04
  #define TIMELIB_ERROR_UNSUPPORTED_VERSION                 0x05
  #define TIMELIB_ERROR_NO_SUCH_TIMEZONE                    0x06
diff --git a/php.spec b/php.spec
index d9f12e0..14c1195 100644
--- a/php.spec
+++ b/php.spec
@@ -160,8 +160,8 @@ Patch10: php-7.0.7-curl.patch
 # Use system nikic/php-parser
 Patch41: php-8.0.0-parser.patch
 # use system tzdata
-Patch42: php-8.1.0-systzdata-v20.patch
-Patch43: php-8.1.0-timelib.patch
+Patch42: php-8.1.0-timelib.patch
+Patch43: php-8.1.0-systzdata-v20.patch
 # See http://bugs.php.net/53436
 Patch44: php-7.4.0-phpize.patch
 # Use -lldap_r for OpenLDAP
@@ -932,9 +932,9 @@ in pure PHP.
 %endif
 
 %patch41 -p1 -b .syslib
+%patch42 -p1 -b .up
 %if %{with tzdata}
-%patch42 -p1 -b .systzdata
-%patch43 -p1 -b .up
+%patch43 -p1 -b .systzdata
 %endif
 %patch44 -p1 -b .headers
 sed -e 's/php-devel/%{?scl_prefix}php-devel/' -i scripts/phpize.in
-- 
cgit