summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION2
-rw-r--r--php-zephir-parser.spec50
3 files changed, 17 insertions, 39 deletions
diff --git a/PHPINFO b/PHPINFO
index 1dd25ca..28bbd01 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -5,5 +5,5 @@ zephir_parser
The Zephir Parser delivered as a C extension for the PHP language.
zephir_parser => enabled
Author => Zephir Team and contributors
-Version => 1.6.1
-Build Date => Jun 4 2024 00:00:00
+Version => 1.7.0
+Build Date => Nov 25 2024 00:00:00
diff --git a/REFLECTION b/REFLECTION
index 859cfe3..15505a1 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #98 zephir_parser version 1.6.1 ] {
+Extension [ <persistent> extension #113 zephir_parser version 1.7.0 ] {
- Functions {
Function [ <internal:zephir_parser> function zephir_parse_file ] {
diff --git a/php-zephir-parser.spec b/php-zephir-parser.spec
index 346fcc1..933b933 100644
--- a/php-zephir-parser.spec
+++ b/php-zephir-parser.spec
@@ -25,7 +25,7 @@
%global _configure ../%{sources}/configure
Name: %{?scl_prefix}%{gh_project}
-Version: 1.6.1
+Version: 1.7.0
Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Summary: Zephir code parser
@@ -34,7 +34,7 @@ URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: http://pecl.php.net/get/%{sources}.tgz
BuildRequires: %{?dtsprefix}gcc
-BuildRequires: %{?scl_prefix}php-devel >= 7.0
+BuildRequires: (%{?scl_prefix}php-devel >= 7.0 with %{?scl_prefix}php-devel < 8.5)
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: re2c >= 0.13.6
@@ -70,7 +70,7 @@ These are the files needed to compile programs using %{name}.
%prep
%setup -qc
-%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
+sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml
pushd %{sources}
# Sanity check, really often broken
@@ -98,13 +98,15 @@ EOF
pushd %{sources}
%{__phpize}
+[ -f Makefile.global ] && GLOBAL=Makefile.global || GLOBAL=build/Makefile.global
+sed -e 's/INSTALL_ROOT/DESTDIR/' -i $GLOBAL
cd ../NTS
%configure \
--with-php-config=%{__phpconfig} \
--enable-zephir_parser
-make %{?_smp_mflags}
+%make_build
popd
%if %{with_zts}
@@ -112,13 +114,14 @@ pushd ZTS
%configure \
--with-php-config=%{__ztsphpconfig} \
--enable-zephir_parser
-make %{?_smp_mflags}
+
+%make_build
popd
%endif
%install
%{?dtsenable}
-make -C NTS install INSTALL_ROOT=%{buildroot}
+%make_install -C NTS
# install config file
install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
@@ -127,7 +130,7 @@ install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
%if %{with_zts}
-make -C ZTS install INSTALL_ROOT=%{buildroot}
+%make_install -C ZTS
install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
@@ -141,26 +144,6 @@ do install -Dpm 644 %{sources}/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
-%if 0%{?fedora} < 24 && 0%{?rhel} < 8
-# when pear installed alone, after us
-%triggerin -- %{?scl_prefix}php-pear
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-# posttrans as pear can be installed after us
-%posttrans
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-%postun
-if [ $1 -eq 0 -a -x %{__pecl} ] ; then
- %{pecl_uninstall} %{pecl_name} >/dev/null || :
-fi
-%endif
-
-
%check
cd %{sources}
@@ -180,19 +163,11 @@ REPORT_EXIT_STATUS=1 \
%if %{with_zts}
: Minimal load test for ZTS extension
%{__ztsphp} -n -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so -m | grep '^%{pecl_name}$'
-
-%if %{with tests}
-: Upstream test suite for ZTS extension
-TEST_PHP_EXECUTABLE=%{__ztsphp} \
-TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
-REPORT_EXIT_STATUS=1 \
-%{__ztsphp} -n run-tests.php -q --show-diff
-%endif
%endif
%files
-%{?_licensedir:%license %{sources}/LICENSE}
+%license %{sources}/LICENSE
%doc %{pecl_docdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
%config(noreplace) %{php_inidir}/%{ini_name}
@@ -213,6 +188,9 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Mon Nov 25 2024 Remi Collet <remi@remirepo.net> - 1.7.0-1
+- update to 1.7.0 (no change)
+
* Tue Jun 4 2024 Remi Collet <remi@remirepo.net> - 1.6.1-1
- update to 1.6.1 (no change)