summaryrefslogtreecommitdiffstats
path: root/php-webmozart-assert.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-webmozart-assert.spec')
-rw-r--r--php-webmozart-assert.spec19
1 files changed, 12 insertions, 7 deletions
diff --git a/php-webmozart-assert.spec b/php-webmozart-assert.spec
index 91b047e..78f9864 100644
--- a/php-webmozart-assert.spec
+++ b/php-webmozart-assert.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-webmozart-assert
#
-# Copyright (c) 2016,2018 Shawn Iwinski <shawn@iwin.ski>
+# Copyright (c) 2016-2019 Shawn Iwinski <shawn@iwin.ski>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -14,8 +14,8 @@
%global bootstrap 0
%global github_owner webmozart
%global github_name assert
-%global github_version 1.3.0
-%global github_commit 0df1908962e7a3071564e857d86874dad1ef204a
+%global github_version 1.4.0
+%global github_commit 83e253c8e0be5b0257b881e1827274667c5c17a9
%global composer_vendor webmozart
%global composer_project assert
@@ -35,10 +35,9 @@
Name: php-%{composer_vendor}-%{composer_project}
Version: %{github_version}
-Release: 3%{?github_release}%{?dist}
+Release: 1%{?github_release}%{?dist}
Summary: Assertions to validate method input/output with nice error messages
-Group: Development/Libraries
License: MIT
URL: https://github.com/%{github_owner}/%{github_name}
@@ -53,10 +52,12 @@ BuildArch: noarch
## composer.json
BuildRequires: php(language) >= %{php_min_ver}
BuildRequires: php-composer(phpunit/phpunit)
-## phpcompatinfo (computed from version 1.3.0)
+## phpcompatinfo (computed from version 1.4.0)
BuildRequires: php-ctype
+BuildRequires: php-filter
BuildRequires: php-mbstring
BuildRequires: php-pcre
+BuildRequires: php-reflection
BuildRequires: php-spl
## Autoloader
BuildRequires: php-composer(fedora/autoloader)
@@ -64,8 +65,9 @@ BuildRequires: php-composer(fedora/autoloader)
# composer.json
Requires: php(language) >= %{php_min_ver}
-# phpcompatinfo (computed from version 1.3.0)
+# phpcompatinfo (computed from version 1.4.0)
Requires: php-ctype
+Requires: php-filter
Requires: php-mbstring
Requires: php-pcre
Requires: php-spl
@@ -144,6 +146,9 @@ exit $RETURN_CODE
%changelog
+* Sun May 19 2019 Shawn Iwinski <shawn@iwin.ski> - 1.4.0-1
+- Update to 1.4.0
+
* Fri Oct 19 2018 Remi Collet <remi@remirepo.net> - 1.3.0-3
- fix autoloader, use PSR-4 to avoid duplicated definition
- prepend autoloader to ensure we use current version in tests