summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json10
-rw-r--r--php-tecnickcom-tc-lib-pdf.spec16
2 files changed, 15 insertions, 11 deletions
diff --git a/composer.json b/composer.json
index 41e31a4..efcd792 100644
--- a/composer.json
+++ b/composer.json
@@ -19,7 +19,7 @@
}
],
"require": {
- "php": ">=8.0",
+ "php": ">=8.1",
"ext-date": "*",
"ext-pcre": "*",
"tecnickcom/tc-lib-barcode": "^2.4",
@@ -34,10 +34,10 @@
"tecnickcom/tc-lib-pdf-graph": "^2.2"
},
"require-dev": {
- "pdepend/pdepend": "2.13.0",
- "phpmd/phpmd": "2.13.0",
- "phpunit/phpunit": "10.1.2 || 9.6.13",
- "squizlabs/php_codesniffer": "3.7.2"
+ "pdepend/pdepend": "2.16.2",
+ "phpmd/phpmd": "2.15.0",
+ "phpunit/phpunit": "11.5.2 || 10.5.40",
+ "squizlabs/php_codesniffer": "3.11.2"
},
"autoload": {
"psr-4": {
diff --git a/php-tecnickcom-tc-lib-pdf.spec b/php-tecnickcom-tc-lib-pdf.spec
index 915209e..bf35625 100644
--- a/php-tecnickcom-tc-lib-pdf.spec
+++ b/php-tecnickcom-tc-lib-pdf.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit c6023354c00eabd29081724a2b789ca354be46c7
+%global gh_commit b9276c9a1a9516431230bb442c45c9024799f42b
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%bcond_without tests
Name: php-%{gh_owner}-%{gh_project}
-Version: 8.0.83
+Version: 8.0.84
Release: 1%{?dist}
Summary: PHP PDF Library
@@ -27,8 +27,8 @@ BuildArch: noarch
%if %{with tests}
# For tests
%global phpunit %{_bindir}/phpunit10
-BuildRequires: phpunit10 >= 10.1.2
-BuildRequires: php(language) >= 8.0
+BuildRequires: phpunit10 >= 10.5.40
+BuildRequires: php(language) >= 8.1
BuildRequires: (php-composer(%{c_vendor}/tc-lib-barcode) >= 2.4 with php-composer(%{c_vendor}/tc-lib-barcode) < 3)
BuildRequires: (php-composer(%{c_vendor}/tc-lib-color) >= 2.2 with php-composer(%{c_vendor}/tc-lib-color) < 3)
BuildRequires: (php-composer(%{c_vendor}/tc-lib-pdf-image) >= 2.1 with php-composer(%{c_vendor}/tc-lib-pdf-image) < 3)
@@ -48,7 +48,7 @@ BuildRequires: php-pecl-imagick
BuildRequires: php-fedora-autoloader-devel
# From composer.json, "require": {
-# "php": ">=8.0",
+# "php": ">=8.1",
# "ext-date": "*",
# "ext-pcre": "*",
# "tecnickcom/tc-lib-barcode": "^2.4",
@@ -61,7 +61,7 @@ BuildRequires: php-fedora-autoloader-devel
# "tecnickcom/tc-lib-unicode": "^2.0",
# "tecnickcom/tc-lib-pdf-page": "^4.2",
# "tecnickcom/tc-lib-pdf-graph": "^2.2"
-Requires: php(language) >= 8.0
+Requires: php(language) >= 8.1
Requires: php-date
Requires: php-pcre
Requires: (php-composer(%{c_vendor}/tc-lib-barcode) >= 2.4 with php-composer(%{c_vendor}/tc-lib-barcode) < 3)
@@ -196,6 +196,10 @@ exit $ret
%changelog
+* Fri Dec 27 2024 Remi Collet <remi@remirepo.net> - 8.0.84-1
+- update to 8.0.84
+- raise dependency on PHP 8.1
+
* Mon Dec 23 2024 Remi Collet <remi@remirepo.net> - 8.0.83-1
- update to 8.0.83
- raise dependency on tecnickcom/tc-lib-file 2.1