summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json10
-rw-r--r--php-tecnickcom-tc-lib-pdf-page.spec16
2 files changed, 15 insertions, 11 deletions
diff --git a/composer.json b/composer.json
index 0aaac9c..5c8e9dc 100644
--- a/composer.json
+++ b/composer.json
@@ -18,17 +18,17 @@
}
],
"require": {
- "php": ">=8.0",
+ "php": ">=8.1",
"ext-date": "*",
"ext-zlib": "*",
"tecnickcom/tc-lib-color": "^2.2",
"tecnickcom/tc-lib-pdf-encrypt": "^2.1"
},
"require-dev": {
- "pdepend/pdepend": "2.13.0",
- "phpmd/phpmd": "2.13.0",
- "phpunit/phpunit": "10.1.2 || 9.6.13",
- "squizlabs/php_codesniffer": "3.7.2"
+ "pdepend/pdepend": "2.16.2",
+ "phpmd/phpmd": "2.15.0",
+ "phpunit/phpunit": "11.5.2 || 10.5.40",
+ "squizlabs/php_codesniffer": "3.11.2"
},
"autoload": {
"psr-4": {
diff --git a/php-tecnickcom-tc-lib-pdf-page.spec b/php-tecnickcom-tc-lib-pdf-page.spec
index 7c6896b..c8b4154 100644
--- a/php-tecnickcom-tc-lib-pdf-page.spec
+++ b/php-tecnickcom-tc-lib-pdf-page.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 6a8d65f6fa50d04e8315feb96a0b5de8e0e1c2e3
+%global gh_commit 66f4b8c6e4642584ceaba14ea040d5fda3ffac16
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 4.2.4
+Version: 4.2.5
Release: 1%{?dist}
Summary: PHP library containing PDF page formats and definitions
@@ -27,8 +27,8 @@ BuildArch: noarch
%if %{with_tests}
# For tests
%global phpunit %{_bindir}/phpunit10
-BuildRequires: phpunit10 >= 10.1.2
-BuildRequires: php(language) >= 8.0
+BuildRequires: phpunit10 >= 10.5.40
+BuildRequires: php(language) >= 8.1
BuildRequires: (php-composer(%{c_vendor}/tc-lib-color) >= 2.2 with php-composer(%{c_vendor}/tc-lib-color) < 3)
BuildRequires: (php-composer(%{c_vendor}/tc-lib-pdf-encrypt) >= 2.1 with php-composer(%{c_vendor}/tc-lib-pdf-encrypt) < 3)
BuildRequires: php-date
@@ -37,12 +37,12 @@ BuildRequires: php-zlib
BuildRequires: php-fedora-autoloader-devel
# From composer.json, "require": {
-# "php": ">=8.0"
+# "php": ">=8.1"
# "ext-date": "*",
# "ext-zlib": "*",
# "tecnickcom/tc-lib-color": "^2.2"
# "tecnickcom/tc-lib-pdf-encrypt": "^2.0",
-Requires: php(language) >= 8.0
+Requires: php(language) >= 8.1
Requires: php-date
Requires: php-zlib
Requires: (php-composer(%{c_vendor}/tc-lib-color) >= 2.2 with php-composer(%{c_vendor}/tc-lib-color) < 3)
@@ -117,6 +117,10 @@ exit $ret
%changelog
+* Fri Dec 27 2024 Remi Collet <remi@remirepo.net> - 4.2.5-1
+- update to 4.2.5
+- raise dependency on PHP 8.1
+
* Mon Dec 23 2024 Remi Collet <remi@remirepo.net> - 4.2.4-1
- update to 4.2.4 (no change)
- re-license spec file to CECILL-2.1