summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json2
-rw-r--r--php-tecnickcom-tc-lib-pdf-font.spec14
2 files changed, 10 insertions, 6 deletions
diff --git a/composer.json b/composer.json
index 5637ba9..3e1d0d4 100644
--- a/composer.json
+++ b/composer.json
@@ -21,7 +21,7 @@
}
],
"require": {
- "php": ">=5.4.0",
+ "php": ">=8.0",
"ext-json": "*",
"ext-pcre": "*",
"ext-zlib": "*",
diff --git a/php-tecnickcom-tc-lib-pdf-font.spec b/php-tecnickcom-tc-lib-pdf-font.spec
index 8cb47ba..9ae5f8e 100644
--- a/php-tecnickcom-tc-lib-pdf-font.spec
+++ b/php-tecnickcom-tc-lib-pdf-font.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit ae38d738c087e2fdb8d1a070cb7998ed5dd1c9e0
+%global gh_commit 6537d65aa7fbc63ab9aae5eb6c69900c6d4b6905
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global c_vendor tecnickcom
%global gh_owner tecnickcom
@@ -16,7 +16,7 @@
%global font_version 2.1.0
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.4.2
+Version: 2.5.0
Release: 1%{?dist}
Summary: PHP library containing PDF page formats and definitions
@@ -33,7 +33,7 @@ BuildArch: noarch
# For tests
%global phpunit %{_bindir}/phpunit10
BuildRequires: phpunit10 >= 10.1.2
-BuildRequires: php(language) >= 5.4
+BuildRequires: php(language) >= 8.0
BuildRequires: php-json
BuildRequires: php-pcre
BuildRequires: php-spl
@@ -45,14 +45,14 @@ BuildRequires: (php-composer(%{c_vendor}/tc-lib-pdf-encrypt) >= 2.1 with ph
BuildRequires: php-fedora-autoloader-devel
# From composer.json, "require": {
-# "php": ">=5.4.0",
+# "php": ">=8.0",
# "ext-json": "*",
# "ext-pcre": "*",
# "ext-zlib": "*",
# "tecnickcom/tc-lib-file": "^2.0",
# "tecnickcom/tc-lib-unicode-data": "^2.0",
# "tecnickcom/tc-lib-pdf-encrypt": "^2.1"
-Requires: php(language) >= 5.4
+Requires: php(language) >= 8.0
Requires: php-json
Requires: php-pcre
Requires: php-spl
@@ -143,6 +143,10 @@ exit $ret
%changelog
+* Mon Aug 26 2024 Remi Collet <remi@remirepo.net> - 2.5.0-1
+- update to 2.5.0
+- raise dependency on PHP 8.0
+
* Mon Aug 19 2024 Remi Collet <remi@remirepo.net> - 2.4.2-1
- update to 2.4.2