summaryrefslogtreecommitdiffstats
path: root/php-sabre-event5.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-sabre-event5.spec')
-rw-r--r--php-sabre-event5.spec7
1 files changed, 7 insertions, 0 deletions
diff --git a/php-sabre-event5.spec b/php-sabre-event5.spec
index f3dd375..c28a53f 100644
--- a/php-sabre-event5.spec
+++ b/php-sabre-event5.spec
@@ -98,6 +98,13 @@ cp -pr lib %{buildroot}%{_datadir}/php/%{ns_vendor}/%{ns_project}%{major}
%check
+: Check version
+php -r '
+require "%{buildroot}%{_datadir}/php/%{ns_vendor}/%{ns_project}%{major}/autoload.php";
+echo Sabre\Event\Version::VERSION . "\n";
+exit (Sabre\Event\Version::VERSION === "%{version}" ? 0 : 1);
+'
+
%if %{with tests}
: Run upstream test suite against installed library
ret=0