summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json2
-rw-r--r--phpunit11.spec18
2 files changed, 12 insertions, 8 deletions
diff --git a/composer.json b/composer.json
index 4134cb2..b666777 100644
--- a/composer.json
+++ b/composer.json
@@ -39,7 +39,7 @@
"phpunit/php-timer": "^7.0.1",
"sebastian/cli-parser": "^3.0.2",
"sebastian/code-unit": "^3.0.2",
- "sebastian/comparator": "^6.2.1",
+ "sebastian/comparator": "^6.3.0",
"sebastian/diff": "^6.0.2",
"sebastian/environment": "^7.2.0",
"sebastian/exporter": "^6.3.0",
diff --git a/phpunit11.spec b/phpunit11.spec
index b73bb4a..4d13536 100644
--- a/phpunit11.spec
+++ b/phpunit11.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for phpunit11
#
-# SPDX-FileCopyrightText: Copyright 2010-2024 Remi Collet
+# SPDX-FileCopyrightText: Copyright 2010-2025 Remi Collet
# SPDX-License-Identifier: CECILL-2.1
# http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
#
@@ -19,8 +19,8 @@
%bcond_with defcmd
%endif
-%global gh_commit 153d0531b9f7e883c5053160cad6dd5ac28140b3
-%global gh_date 2024-12-21
+%global gh_commit 30e319e578a7b5da3543073e30002bf82042f701
+%global gh_date 2025-01-13
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project phpunit
@@ -33,7 +33,7 @@
%global ver_major 11
%global ver_minor 5
-%global upstream_version 11.5.2
+%global upstream_version 11.5.3
#global upstream_prever dev
Name: %{pk_project}%{ver_major}
@@ -62,7 +62,7 @@ BuildRequires: (php-composer(phpunit/php-text-template) >= 4.0.1 with php-c
BuildRequires: (php-composer(phpunit/php-timer) >= 7.0.1 with php-composer(phpunit/php-timer) < 8)
BuildRequires: (php-composer(sebastian/cli-parser) >= 3.0.2 with php-composer(sebastian/cli-parser) < 4)
BuildRequires: (php-composer(sebastian/code-unit) >= 3.0.2 with php-composer(sebastian/code-unit) < 4)
-BuildRequires: (php-composer(sebastian/comparator) >= 6.2.1 with php-composer(sebastian/comparator) < 7)
+BuildRequires: (php-composer(sebastian/comparator) >= 6.3.0 with php-composer(sebastian/comparator) < 7)
BuildRequires: (php-composer(sebastian/diff) >= 6.0.2 with php-composer(sebastian/diff) < 7)
BuildRequires: (php-composer(sebastian/environment) >= 7.2.0 with php-composer(sebastian/environment) < 8)
BuildRequires: (php-composer(sebastian/exporter) >= 6.3.0 with php-composer(sebastian/exporter) < 7)
@@ -98,7 +98,7 @@ BuildRequires: php-fedora-autoloader-devel >= 1.0.0
# "phpunit/php-timer": "^7.0.1",
# "sebastian/cli-parser": "^3.0.2",
# "sebastian/code-unit": "^3.0.2",
-# "sebastian/comparator": "^6.2.1",
+# "sebastian/comparator": "^6.3.0",
# "sebastian/diff": "^6.0.2",
# "sebastian/environment": "^7.2.0",
# "sebastian/exporter": "^6.3.0",
@@ -125,7 +125,7 @@ Requires: (php-composer(phpunit/php-text-template) >= 4.0.1 with php-c
Requires: (php-composer(phpunit/php-timer) >= 7.0.1 with php-composer(phpunit/php-timer) < 8)
Requires: (php-composer(sebastian/cli-parser) >= 3.0.2 with php-composer(sebastian/cli-parser) < 4)
Requires: (php-composer(sebastian/code-unit) >= 3.0.2 with php-composer(sebastian/code-unit) < 4)
-Requires: (php-composer(sebastian/comparator) >= 6.2.1 with php-composer(sebastian/comparator) < 7)
+Requires: (php-composer(sebastian/comparator) >= 6.3.0 with php-composer(sebastian/comparator) < 7)
Requires: (php-composer(sebastian/diff) >= 6.0.2 with php-composer(sebastian/diff) < 7)
Requires: (php-composer(sebastian/environment) >= 7.2.0 with php-composer(sebastian/environment) < 8)
Requires: (php-composer(sebastian/exporter) >= 6.3.0 with php-composer(sebastian/exporter) < 7)
@@ -297,6 +297,10 @@ exit $ret
%changelog
+* Mon Jan 13 2025 Remi Collet <remi@remirepo.net> - 11.5.3-1
+- update to 11.5.3
+- raise dependency on sebastian/comparator 6.3.0
+
* Sun Dec 22 2024 Remi Collet <remi@remirepo.net> - 11.5.2-1
- update to 11.5.2
- raise dependency on phpunit/php-code-coverage 11.0.8