summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json2
-rwxr-xr-xmakesrc.sh2
-rw-r--r--php-phpunit-php-code-coverage11.spec20
3 files changed, 14 insertions, 10 deletions
diff --git a/composer.json b/composer.json
index 431570a..a9d0076 100644
--- a/composer.json
+++ b/composer.json
@@ -44,7 +44,7 @@
"theseer/tokenizer": "^1.2.3"
},
"require-dev": {
- "phpunit/phpunit": "^11.4.1"
+ "phpunit/phpunit": "^11.5.0"
},
"suggest": {
"ext-pcov": "PHP extension that provides line coverage",
diff --git a/makesrc.sh b/makesrc.sh
index b959795..2f4838e 100755
--- a/makesrc.sh
+++ b/makesrc.sh
@@ -17,7 +17,7 @@ else
echo "Cloning..."
rm -rf $PROJECT-$COMMIT
- git clone --shallow-since=$DATE https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT || exit 1
+ git clone --branch ${VERSION:0:4} --shallow-since=$DATE https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT || exit 1
echo "Getting commit..."
pushd $PROJECT-$COMMIT
diff --git a/php-phpunit-php-code-coverage11.spec b/php-phpunit-php-code-coverage11.spec
index f52aa80..6cb76bc 100644
--- a/php-phpunit-php-code-coverage11.spec
+++ b/php-phpunit-php-code-coverage11.spec
@@ -1,8 +1,8 @@
# remirepo/fedora spec file for php-phpunit-php-code-coverage11
#
-# Copyright (c) 2013-2024 Remi Collet
-# License: CC-BY-SA-4.0
-# http://creativecommons.org/licenses/by-sa/4.0/
+# SPDX-FileCopyrightText: Copyright 2024 Remi Collet
+# SPDX-License-Identifier: CECILL-2.1
+# http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
#
# Please, preserve the changelog entries
#
@@ -11,11 +11,11 @@
%bcond_with tests
# Github
-%global gh_commit f7f08030e8811582cc459871d28d6f5a1a4d35ca
+%global gh_commit 418c59fd080954f8c4aa5631d9502ecda2387118
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project php-code-coverage
-%global gh_date 2024-10-09
+%global gh_date 2024-12-11
# Packagist
%global pk_vendor phpunit
%global pk_project php-code-coverage
@@ -26,7 +26,7 @@
%global ver_major 11
Name: php-%{pk_vendor}-%{pk_project}%{ver_major}
-Version: 11.0.7
+Version: 11.0.8
Release: 1%{?dist}
Summary: PHP code coverage information, version %{ver_major}
@@ -63,8 +63,8 @@ BuildRequires: php-spl
BuildRequires: php-tokenizer
BuildRequires: php-xmlwriter
# From composer.json, "require-dev": {
-# "phpunit/phpunit": "^11.4.1"
-BuildRequires: phpunit11 >= 11.4.1
+# "phpunit/phpunit": "^11.5.0"
+BuildRequires: phpunit11 >= 11.5.0
BuildRequires: php-xdebug
%endif
@@ -202,6 +202,10 @@ exit $ret
%changelog
+* Wed Dec 11 2024 Remi Collet <remi@remirepo.net> - 11.0.8-1
+- update to 11.0.8
+- re-license spec file to CECILL-2.1
+
* Wed Oct 9 2024 Remi Collet <remi@remirepo.net> - 11.0.7-1
- update to 11.0.7
- raise dependency on nikic/php-parser 5.3.1