diff options
-rw-r--r-- | failed.txt | 17 | ||||
-rw-r--r-- | php-upstream.patch | 57 | ||||
-rw-r--r-- | php71.spec | 20 |
3 files changed, 27 insertions, 67 deletions
@@ -1,4 +1,4 @@ -===== 7.1.3RC1 (2017-03-02) +===== 7.1.3 (2017-03-16) $ grep -r 'Tests failed' /var/lib/mock/*/build.log @@ -11,11 +11,22 @@ $ grep -r 'Tests failed' /var/lib/mock/*/build.log /var/lib/mock/fc24x/build.log:Tests failed : 0 /var/lib/mock/fc25i/build.log:Tests failed : 0 /var/lib/mock/fc25x/build.log:Tests failed : 0 +/var/lib/mock/fc26i/build.log:Tests failed : 9 +/var/lib/mock/fc26x/build.log:Tests failed : 9 - +fc26i, fc26x + Bug #20382 [2] (strtotime ("Monday", $date) produces wrong result on DST changeover) [ext/date/tests/bug20382-2.phpt] + Bug #27780 (strtotime(+1 xxx) returns a wrong date/time) [ext/date/tests/bug27780.phpt] + Bug #32086 (strtotime don't work in DST) [ext/date/tests/bug32086.phpt] + Bug #33414 [1] (Comprehensive list of incorrect days returned after strotime() / date() tests) [ext/date/tests/bug33414-1.phpt] + Bug #33414 [2] (Comprehensive list of incorrect days returned after strotime() / date() tests) [ext/date/tests/bug33414-2.phpt] + Bug #33415 [1] (Possibly invalid non-one-hour DST or timezone shifts) [ext/date/tests/bug33415-1.phpt] + Bug #33415 [2] (Possibly invalid non-one-hour DST or timezone shifts) [ext/date/tests/bug33415-2.phpt] + date_modify() function [1] [ext/date/tests/date_modify-1.phpt] + sni_server [ext/openssl/tests/sni_server.phpt] * proc_open give erratic test results :( ** date tests vary with tzdata available in system -*** test fixed upstream +*** f26 failures related to tzdata 2016j vs 2017a and sni_server is a known issue with openssl 1.1 diff --git a/php-upstream.patch b/php-upstream.patch deleted file mode 100644 index c1e0abf..0000000 --- a/php-upstream.patch +++ /dev/null @@ -1,57 +0,0 @@ -From 3006d1de5b1b2903af3ad1e8c72c3cfe6cd1af15 Mon Sep 17 00:00:00 2001 -From: Remi Collet <remi@php.net> -Date: Tue, 28 Feb 2017 11:36:24 +0100 -Subject: [PATCH] make test slower again - ---- - Zend/tests/bug74093.phpt | 40 ++++++++++++++++++++-------------------- - 1 file changed, 20 insertions(+), 20 deletions(-) - -diff --git a/Zend/tests/bug74093.phpt b/Zend/tests/bug74093.phpt -index 22c78a6..7f20285 100644 ---- a/Zend/tests/bug74093.phpt -+++ b/Zend/tests/bug74093.phpt -@@ -1,20 +1,20 @@ ----TEST--
--Bug #74093 (Maximum execution time of n+2 seconds exceed not written in error_log)
----SKIPIF--
--<?php
--if (getenv("SKIP_SLOW_TESTS")) die("skip slow test");
--if (PHP_ZTS) die("skip only for no-zts build");
--if (substr(PHP_OS, 0, 3) == 'WIN') die("skip not for Windows");
--?>
----INI--
--memory_limit=1G
--max_execution_time=1
--hard_timeout=1
----FILE--
--<?php
--$a1 = range(1, 1000000);
--$a2 = range(100000, 999999);
--array_intersect($a1, $a2);
--?>
----EXPECTF--
--Fatal error: Maximum execution time of 1+1 seconds exceeded %s
-+--TEST-- -+Bug #74093 (Maximum execution time of n+2 seconds exceed not written in error_log) -+--SKIPIF-- -+<?php -+if (getenv("SKIP_SLOW_TESTS")) die("skip slow test"); -+if (PHP_ZTS) die("skip only for no-zts build"); -+if (substr(PHP_OS, 0, 3) == 'WIN') die("skip not for Windows"); -+?> -+--INI-- -+memory_limit=1G -+max_execution_time=1 -+hard_timeout=1 -+--FILE-- -+<?php -+$a1 = range(1, 1000000); -+$a2 = range(100000, 1999999); -+array_intersect($a1, $a2); -+?> -+--EXPECTF-- -+Fatal error: Maximum execution time of 1+1 seconds exceeded %s --- -2.1.4 - @@ -120,8 +120,8 @@ %global db_devel libdb-devel %endif -%global rcver RC1 -%global rpmrel 2 +#global rcver RC1 +%global rpmrel 1 Summary: PHP scripting language for creating dynamic web sites Name: php @@ -177,7 +177,6 @@ Patch47: php-5.6.3-phpinfo.patch Patch91: php-5.6.3-oci8conf.patch # Upstream fixes (100+) -Patch100: php-upstream.patch # Security fixes (200+) @@ -1027,7 +1026,6 @@ httpd -V | grep -q 'threaded:.*yes' && exit 1 %patch91 -p1 -b .remi-oci8 # upstream patches -%patch100 -p1 -b .upstream # security patches @@ -1649,13 +1647,13 @@ mv $RPM_BUILD_ROOT%{_sysconfdir}/php-fpm.d/www.conf.default . # LogRotate install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d install -m 644 %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/php-fpm + # Environment file -%if 0%{?fedora} >= 26 -sed -e '/EnvironmentFile/d' -i $RPM_BUILD_ROOT%{_unitdir}/%{?scl_prefix}php-fpm.service -%else +%if 0%{?fedora} < 26 install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig install -m 644 %{SOURCE8} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/php-fpm %endif + %if %{with_systemd} install -m 755 -d $RPM_BUILD_ROOT/run/php-fpm # tmpfiles.d @@ -1675,6 +1673,11 @@ sed -i -e 's:/run:/var/run:' $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/php-fpm install -m 755 -d $RPM_BUILD_ROOT%{_initrddir} install -m 755 %{SOURCE99} $RPM_BUILD_ROOT%{_initrddir}/php-fpm %endif + +%if 0%{?fedora} >= 26 +sed -e '/EnvironmentFile/d' -i $RPM_BUILD_ROOT%{_unitdir}/php-fpm.service +%endif + %if %{with_nginx} # Nginx configuration install -D -m 644 %{SOURCE13} $RPM_BUILD_ROOT%{_sysconfdir}/nginx/conf.d/php-fpm.conf @@ -2055,6 +2058,9 @@ fi %changelog +* Tue Mar 14 2017 Remi Collet <remi@fedoraproject.org> - 7.1.3-1 +- Update to 7.1.3 - http://www.php.net/releases/7_1_3.php + * Fri Mar 10 2017 Remi Collet <remi@fedoraproject.org> 7.1.3-0.2.RC1 - fix interbase build on F26 |