From eb69098915628094a5825b9eaa9a7a128e9ff9dc Mon Sep 17 00:00:00 2001
From: Remi Collet <fedora@famillecollet.com>
Date: Mon, 23 Sep 2013 13:27:44 +0200
Subject: php test build

---
 php-wip.patch | 69 +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
 php55.spec    |  9 +++++---
 2 files changed, 75 insertions(+), 3 deletions(-)
 create mode 100644 php-wip.patch

diff --git a/php-wip.patch b/php-wip.patch
new file mode 100644
index 0000000..6aee5a9
--- /dev/null
+++ b/php-wip.patch
@@ -0,0 +1,69 @@
+diff --git a/Zend/zend_exceptions.c b/Zend/zend_exceptions.c
+index 14ae75e..c7f157c 100644
+--- a/Zend/zend_exceptions.c
++++ b/Zend/zend_exceptions.c
+@@ -560,7 +560,7 @@ ZEND_METHOD(exception, getPrevious)
+ 	RETURN_ZVAL(previous, 1, 0);
+ }
+ 
+-int zend_spprintf(char **message, int max_len, char *format, ...) /* {{{ */
++int zend_spprintf(char **message, int max_len, const char *format, ...) /* {{{ */
+ {
+ 	va_list arg;
+ 	int len;
+@@ -732,7 +732,7 @@ ZEND_API zend_class_entry *zend_get_error_exception(TSRMLS_D) /* {{{ */
+ }
+ /* }}} */
+ 
+-ZEND_API zval * zend_throw_exception(zend_class_entry *exception_ce, char *message, long code TSRMLS_DC) /* {{{ */
++ZEND_API zval * zend_throw_exception(zend_class_entry *exception_ce, const char *message, long code TSRMLS_DC) /* {{{ */
+ {
+ 	zval *ex;
+ 
+@@ -760,7 +760,7 @@ ZEND_API zval * zend_throw_exception(zend_class_entry *exception_ce, char *messa
+ }
+ /* }}} */
+ 
+-ZEND_API zval * zend_throw_exception_ex(zend_class_entry *exception_ce, long code TSRMLS_DC, char *format, ...) /* {{{ */
++ZEND_API zval * zend_throw_exception_ex(zend_class_entry *exception_ce, long code TSRMLS_DC, const char *format, ...) /* {{{ */
+ {
+ 	va_list arg;
+ 	char *message;
+@@ -775,7 +775,7 @@ ZEND_API zval * zend_throw_exception_ex(zend_class_entry *exception_ce, long cod
+ }
+ /* }}} */
+ 
+-ZEND_API zval * zend_throw_error_exception(zend_class_entry *exception_ce, char *message, long code, int severity TSRMLS_DC) /* {{{ */
++ZEND_API zval * zend_throw_error_exception(zend_class_entry *exception_ce, const char *message, long code, int severity TSRMLS_DC) /* {{{ */
+ {
+ 	zval *ex = zend_throw_exception(exception_ce, message, code TSRMLS_CC);
+ 	zend_update_property_long(default_exception_ce, ex, "severity", sizeof("severity")-1, severity TSRMLS_CC);
+diff --git a/Zend/zend_exceptions.h b/Zend/zend_exceptions.h
+index 8263353..81c8a1f 100644
+--- a/Zend/zend_exceptions.h
++++ b/Zend/zend_exceptions.h
+@@ -40,12 +40,12 @@ ZEND_API void zend_register_default_classes(TSRMLS_D);
+ 
+ /* exception_ce   NULL or zend_exception_get_default() or a derived class
+  * message        NULL or the message of the exception */
+-ZEND_API zval * zend_throw_exception(zend_class_entry *exception_ce, char *message, long code TSRMLS_DC);
+-ZEND_API zval * zend_throw_exception_ex(zend_class_entry *exception_ce, long code TSRMLS_DC, char *format, ...);
++ZEND_API zval * zend_throw_exception(zend_class_entry *exception_ce, const char *message, long code TSRMLS_DC);
++ZEND_API zval * zend_throw_exception_ex(zend_class_entry *exception_ce, long code TSRMLS_DC, const char *format, ...);
+ ZEND_API void zend_throw_exception_object(zval *exception TSRMLS_DC);
+ ZEND_API void zend_clear_exception(TSRMLS_D);
+ 
+-ZEND_API zval * zend_throw_error_exception(zend_class_entry *exception_ce, char *message, long code, int severity TSRMLS_DC);
++ZEND_API zval * zend_throw_error_exception(zend_class_entry *exception_ce, const char *message, long code, int severity TSRMLS_DC);
+ 
+ extern ZEND_API void (*zend_throw_exception_hook)(zval *ex TSRMLS_DC);
+ 
+@@ -53,7 +53,7 @@ extern ZEND_API void (*zend_throw_exception_hook)(zval *ex TSRMLS_DC);
+ ZEND_API void zend_exception_error(zval *exception, int severity TSRMLS_DC);
+ 
+ /* do not export, in php it's available thru spprintf directly */
+-int zend_spprintf(char **message, int max_len, char *format, ...);
++int zend_spprintf(char **message, int max_len, const char *format, ...);
+ 
+ END_EXTERN_C()
+ 
diff --git a/php55.spec b/php55.spec
index 6e1dc7b..fd05133 100644
--- a/php55.spec
+++ b/php55.spec
@@ -88,7 +88,7 @@ Version: 5.5.4
 %if 0%{?snapdate:1}%{?rcver:1}
 Release: 0.1.%{?snapdate}%{?rcver}%{?dist}
 %else
-Release: 1%{?dist}
+Release: 2%{?dist}
 %endif
 # All files licensed under PHP version 3.01, except
 # Zend is licensed under Zend
@@ -153,7 +153,7 @@ Patch47: php-5.4.9-phpinfo.patch
 Patch91: php-5.3.7-oci8conf.patch
 
 # WIP
-#Patch99: php-wip.patch
+Patch99: php-wip.patch
 
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
 
@@ -855,7 +855,7 @@ rm -rf ext/json
 %patch91 -p1 -b .remi-oci8
 
 # wip patches
-#patch99 -p0 -b .wip
+%patch99 -p1 -b .wip
 
 # Prevent %%doc confusion over LICENSE files
 cp Zend/LICENSE Zend/ZEND_LICENSE
@@ -1822,6 +1822,9 @@ fi
 
 
 %changelog
+* Mon Sep 23 2013 Remi Collet <rcollet@redhat.com> - 5.5.4-2
+- test build
+
 * Thu Sep 19 2013 Remi Collet <rcollet@redhat.com> - 5.5.4-1
 - update to 5.5.4
 - improve security, use specific soap.wsdl_cache_dir
-- 
cgit