From 0d0834a5b415a6f9b64d738fa09521fb11c8600d Mon Sep 17 00:00:00 2001
From: Remi Collet <fedora@famillecollet.com>
Date: Wed, 16 Jul 2014 11:13:55 +0200
Subject: php 5.5.14 + upstream patch for #67605

---
 php-intl.patch | 20 ++++++++++++++++++++
 php55.spec     | 11 ++++++++---
 2 files changed, 28 insertions(+), 3 deletions(-)
 create mode 100644 php-intl.patch

diff --git a/php-intl.patch b/php-intl.patch
new file mode 100644
index 0000000..182e2ef
--- /dev/null
+++ b/php-intl.patch
@@ -0,0 +1,20 @@
+--- php-5.5.14/ext/intl/locale/locale_methods.c	2014-06-25 15:06:23.000000000 +0200
++++ php-5.5.15RC1/ext/intl/locale/locale_methods.c	2014-07-08 23:55:31.000000000 +0200
+@@ -279,7 +279,7 @@
+ 	if( fromParseLocale==1 ){
+ 		/* Handle singletons */
+ 		if( strcmp(tag_name , LOC_LANG_TAG)==0 ){
+-			if( strlen(loc_name)>1 && isIDPrefix(loc_name) ){
++			if( strlen(loc_name)>1 && (isIDPrefix(loc_name) == 1) ){
+ 				return estrdup(loc_name);
+ 			}
+ 		}
+@@ -506,7 +506,7 @@
+     }
+ 
+ 	if(loc_name_len == 0) {
+-		loc_name = INTL_G(default_locale);
++		loc_name = intl_locale_get_default(TSRMLS_C);
+ 	}
+ 
+ 	if( strcmp(tag_name, DISP_NAME) != 0 ){
diff --git a/php55.spec b/php55.spec
index 708a0ab..4b6fc34 100644
--- a/php55.spec
+++ b/php55.spec
@@ -121,15 +121,15 @@
 %endif
 
 #global snapdate      201308300430
-%global rcver         RC1
+#global rcver         RC1
 
 Summary: PHP scripting language for creating dynamic web sites
 Name: php
-Version: 5.5.15
+Version: 5.5.14
 %if 0%{?snapdate:1}%{?rcver:1}
 Release: 0.1.%{?snapdate}%{?rcver}%{?dist}
 %else
-Release: 1%{?dist}
+Release: 2%{?dist}
 %endif
 # All files licensed under PHP version 3.01, except
 # Zend is licensed under Zend
@@ -190,6 +190,7 @@ Patch47: php-5.4.9-phpinfo.patch
 Patch91: php-5.3.7-oci8conf.patch
 
 # Upstream fixes (100+)
+Patch100: php-intl.patch
 
 # Security fixes (200+)
 
@@ -923,6 +924,7 @@ rm -rf ext/json
 %patch91 -p1 -b .remi-oci8
 
 # upstream patches
+%patch100 -p1 -b .intl
 
 # security patches
 
@@ -1927,6 +1929,9 @@ fi
 
 
 %changelog
+* Wed Jul 16 2014 Remi Collet <remi@fedoraproject.org> 5.5.14-2
+- add upstream patch for #67605
+
 * Thu Jul 10 2014 Remi Collet <remi@fedoraproject.org> 5.5.15-0.1.RC1
 - Test build of 5.5.15RC1
 - add php-litespeed subpackage (/usr/bin/lsphp)
-- 
cgit