diff options
-rw-r--r-- | Makefile | 8 | ||||
-rw-r--r-- | tembed.c | 15 |
2 files changed, 22 insertions, 1 deletions
@@ -1,4 +1,10 @@ SRCDIR := $(shell pwd) -NAME := $(shell basename $(SRCDIR)) +NAME := $(shell basename $(SRCDIR)) +INCL1 := $(shell php-config --includes) +INCL2 := -I $(shell php-config --include-dir)/sapi/embed +LIBS := -lphp5 $(shell php-config --libs) + include ../../common/Makefile +tembed: tembed.c + gcc -Wall $(INCL1) $(INCL2) tembed.c $(LIBS) -o tembed diff --git a/tembed.c b/tembed.c new file mode 100644 index 0000000..60595ea --- /dev/null +++ b/tembed.c @@ -0,0 +1,15 @@ +#include <stdio.h> +#include <php_embed.h> + +int main (int argc, char*argv[]) { + PHP_EMBED_START_BLOCK(argc, argv) + zval ver; + zend_eval_string("phpversion();", &ver, "Get version" TSRMLS_CC); + convert_to_string(&ver); + php_printf("Build PHP Version: %s\n", PHP_VERSION); + php_printf("Running PHP Version: %s\n", Z_STRVAL(ver)); + zval_dtor(&ver); + PHP_EMBED_END_BLOCK() + + return 0; +} |