summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json2
-rw-r--r--installed.json110
-rw-r--r--php-cs-fixer.spec28
3 files changed, 77 insertions, 63 deletions
diff --git a/composer.json b/composer.json
index 5887236..a5dfe0e 100644
--- a/composer.json
+++ b/composer.json
@@ -42,7 +42,7 @@
"symfony/polyfill-mbstring": "^1.28",
"symfony/polyfill-php80": "^1.28",
"symfony/polyfill-php81": "^1.28",
- "symfony/process": "^5.4 || ^6.0 || ^7.0",
+ "symfony/process": "^5.4 || ^6.0 || ^7.0 <7.2",
"symfony/stopwatch": "^5.4 || ^6.0 || ^7.0"
},
"require-dev": {
diff --git a/installed.json b/installed.json
index a7ee4a4..853c819 100644
--- a/installed.json
+++ b/installed.json
@@ -96,13 +96,13 @@
"time": "2024-11-12T16:29:46+00:00",
"type": "library",
"extra": {
- "branch-alias": {
- "dev-main": "3.x-dev"
- },
"phpstan": {
"includes": [
"extension.neon"
]
+ },
+ "branch-alias": {
+ "dev-main": "3.x-dev"
}
},
"installation-source": "dist",
@@ -1298,31 +1298,31 @@
},
{
"name": "symfony/deprecation-contracts",
- "version": "v3.5.0",
- "version_normalized": "3.5.0.0",
+ "version": "v3.5.1",
+ "version_normalized": "3.5.1.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/deprecation-contracts.git",
- "reference": "0e0d29ce1f20deffb4ab1b016a7257c4f1e789a1"
+ "reference": "74c71c939a79f7d5bf3c1ce9f5ea37ba0114c6f6"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/deprecation-contracts/zipball/0e0d29ce1f20deffb4ab1b016a7257c4f1e789a1",
- "reference": "0e0d29ce1f20deffb4ab1b016a7257c4f1e789a1",
+ "url": "https://api.github.com/repos/symfony/deprecation-contracts/zipball/74c71c939a79f7d5bf3c1ce9f5ea37ba0114c6f6",
+ "reference": "74c71c939a79f7d5bf3c1ce9f5ea37ba0114c6f6",
"shasum": ""
},
"require": {
"php": ">=8.1"
},
- "time": "2024-04-18T09:32:20+00:00",
+ "time": "2024-09-25T14:20:29+00:00",
"type": "library",
"extra": {
+ "thanks": {
+ "url": "https://github.com/symfony/contracts",
+ "name": "symfony/contracts"
+ },
"branch-alias": {
"dev-main": "3.5-dev"
- },
- "thanks": {
- "name": "symfony/contracts",
- "url": "https://github.com/symfony/contracts"
}
},
"installation-source": "dist",
@@ -1348,7 +1348,7 @@
"description": "A generic function and convention to trigger deprecation notices",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/deprecation-contracts/tree/v3.5.0"
+ "source": "https://github.com/symfony/deprecation-contracts/tree/v3.5.1"
},
"funding": [
{
@@ -1451,32 +1451,32 @@
},
{
"name": "symfony/event-dispatcher-contracts",
- "version": "v3.5.0",
- "version_normalized": "3.5.0.0",
+ "version": "v3.5.1",
+ "version_normalized": "3.5.1.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/event-dispatcher-contracts.git",
- "reference": "8f93aec25d41b72493c6ddff14e916177c9efc50"
+ "reference": "7642f5e970b672283b7823222ae8ef8bbc160b9f"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/event-dispatcher-contracts/zipball/8f93aec25d41b72493c6ddff14e916177c9efc50",
- "reference": "8f93aec25d41b72493c6ddff14e916177c9efc50",
+ "url": "https://api.github.com/repos/symfony/event-dispatcher-contracts/zipball/7642f5e970b672283b7823222ae8ef8bbc160b9f",
+ "reference": "7642f5e970b672283b7823222ae8ef8bbc160b9f",
"shasum": ""
},
"require": {
"php": ">=8.1",
"psr/event-dispatcher": "^1"
},
- "time": "2024-04-18T09:32:20+00:00",
+ "time": "2024-09-25T14:20:29+00:00",
"type": "library",
"extra": {
+ "thanks": {
+ "url": "https://github.com/symfony/contracts",
+ "name": "symfony/contracts"
+ },
"branch-alias": {
"dev-main": "3.5-dev"
- },
- "thanks": {
- "name": "symfony/contracts",
- "url": "https://github.com/symfony/contracts"
}
},
"installation-source": "dist",
@@ -1510,7 +1510,7 @@
"standards"
],
"support": {
- "source": "https://github.com/symfony/event-dispatcher-contracts/tree/v3.5.0"
+ "source": "https://github.com/symfony/event-dispatcher-contracts/tree/v3.5.1"
},
"funding": [
{
@@ -1666,24 +1666,24 @@
},
{
"name": "symfony/options-resolver",
- "version": "v6.4.13",
- "version_normalized": "6.4.13.0",
+ "version": "v6.4.16",
+ "version_normalized": "6.4.16.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/options-resolver.git",
- "reference": "0a62a9f2504a8dd27083f89d21894ceb01cc59db"
+ "reference": "368128ad168f20e22c32159b9f761e456cec0c78"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/options-resolver/zipball/0a62a9f2504a8dd27083f89d21894ceb01cc59db",
- "reference": "0a62a9f2504a8dd27083f89d21894ceb01cc59db",
+ "url": "https://api.github.com/repos/symfony/options-resolver/zipball/368128ad168f20e22c32159b9f761e456cec0c78",
+ "reference": "368128ad168f20e22c32159b9f761e456cec0c78",
"shasum": ""
},
"require": {
"php": ">=8.1",
"symfony/deprecation-contracts": "^2.5|^3"
},
- "time": "2024-09-25T14:18:03+00:00",
+ "time": "2024-11-20T10:57:02+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1716,7 +1716,7 @@
"options"
],
"support": {
- "source": "https://github.com/symfony/options-resolver/tree/v6.4.13"
+ "source": "https://github.com/symfony/options-resolver/tree/v6.4.16"
},
"funding": [
{
@@ -1762,8 +1762,8 @@
"type": "library",
"extra": {
"thanks": {
- "name": "symfony/polyfill",
- "url": "https://github.com/symfony/polyfill"
+ "url": "https://github.com/symfony/polyfill",
+ "name": "symfony/polyfill"
}
},
"installation-source": "dist",
@@ -1841,8 +1841,8 @@
"type": "library",
"extra": {
"thanks": {
- "name": "symfony/polyfill",
- "url": "https://github.com/symfony/polyfill"
+ "url": "https://github.com/symfony/polyfill",
+ "name": "symfony/polyfill"
}
},
"installation-source": "dist",
@@ -1922,8 +1922,8 @@
"type": "library",
"extra": {
"thanks": {
- "name": "symfony/polyfill",
- "url": "https://github.com/symfony/polyfill"
+ "url": "https://github.com/symfony/polyfill",
+ "name": "symfony/polyfill"
}
},
"installation-source": "dist",
@@ -2009,8 +2009,8 @@
"type": "library",
"extra": {
"thanks": {
- "name": "symfony/polyfill",
- "url": "https://github.com/symfony/polyfill"
+ "url": "https://github.com/symfony/polyfill",
+ "name": "symfony/polyfill"
}
},
"installation-source": "dist",
@@ -2086,8 +2086,8 @@
"type": "library",
"extra": {
"thanks": {
- "name": "symfony/polyfill",
- "url": "https://github.com/symfony/polyfill"
+ "url": "https://github.com/symfony/polyfill",
+ "name": "symfony/polyfill"
}
},
"installation-source": "dist",
@@ -2169,8 +2169,8 @@
"type": "library",
"extra": {
"thanks": {
- "name": "symfony/polyfill",
- "url": "https://github.com/symfony/polyfill"
+ "url": "https://github.com/symfony/polyfill",
+ "name": "symfony/polyfill"
}
},
"installation-source": "dist",
@@ -2292,17 +2292,17 @@
},
{
"name": "symfony/service-contracts",
- "version": "v3.5.0",
- "version_normalized": "3.5.0.0",
+ "version": "v3.5.1",
+ "version_normalized": "3.5.1.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/service-contracts.git",
- "reference": "bd1d9e59a81d8fa4acdcea3f617c581f7475a80f"
+ "reference": "e53260aabf78fb3d63f8d79d69ece59f80d5eda0"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/service-contracts/zipball/bd1d9e59a81d8fa4acdcea3f617c581f7475a80f",
- "reference": "bd1d9e59a81d8fa4acdcea3f617c581f7475a80f",
+ "url": "https://api.github.com/repos/symfony/service-contracts/zipball/e53260aabf78fb3d63f8d79d69ece59f80d5eda0",
+ "reference": "e53260aabf78fb3d63f8d79d69ece59f80d5eda0",
"shasum": ""
},
"require": {
@@ -2313,15 +2313,15 @@
"conflict": {
"ext-psr": "<1.1|>=2"
},
- "time": "2024-04-18T09:32:20+00:00",
+ "time": "2024-09-25T14:20:29+00:00",
"type": "library",
"extra": {
+ "thanks": {
+ "url": "https://github.com/symfony/contracts",
+ "name": "symfony/contracts"
+ },
"branch-alias": {
"dev-main": "3.5-dev"
- },
- "thanks": {
- "name": "symfony/contracts",
- "url": "https://github.com/symfony/contracts"
}
},
"installation-source": "dist",
@@ -2358,7 +2358,7 @@
"standards"
],
"support": {
- "source": "https://github.com/symfony/service-contracts/tree/v3.5.0"
+ "source": "https://github.com/symfony/service-contracts/tree/v3.5.1"
},
"funding": [
{
diff --git a/php-cs-fixer.spec b/php-cs-fixer.spec
index 04fd6f4..4ac620f 100644
--- a/php-cs-fixer.spec
+++ b/php-cs-fixer.spec
@@ -7,17 +7,20 @@
# Please, preserve the changelog entries
#
+# remirepo:3
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 79d4f3e77b250a7d8043d76c6af8f0695e8a469f
+%bcond_with generators
+
+%global gh_commit 5f5f2a142ff36b93c41885bca29cc5f861c013e6
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_date 2024-11-25
+%global gh_date 2024-12-29
%global gh_owner FriendsOfPHP
%global gh_project PHP-CS-Fixer
Name: php-cs-fixer
-Version: 3.65.0
+Version: 3.66.0
Release: 1%{?dist}
Summary: PHP Coding Standards Fixer
@@ -35,6 +38,9 @@ BuildArch: noarch
BuildRequires: php(language) >= 8.1
BuildRequires: php-cli
BuildRequires: php-json
+%if %{with generators}
+BuildRequires: composer-generators
+%endif
# see composer.json and makesrc.sh
Requires: php(language) >= 8.1
@@ -49,6 +55,7 @@ Requires: php-mbstring
Obsoletes: php-cs-fixer3 < 3.5
Provides: php-cs-fixer3 = %{version}
+%if %{without generators}
# Bundled PHP libraries
# License BSD-3-Clause
Provides: bundled(php-composer(sebastian/diff)) = 5.1.1
@@ -70,12 +77,12 @@ Provides: bundled(php-composer(react/promise)) = v3.2.0
Provides: bundled(php-composer(react/socket)) = v1.16.0
Provides: bundled(php-composer(react/stream)) = v1.4.0
Provides: bundled(php-composer(symfony/console)) = v6.4.15
-Provides: bundled(php-composer(symfony/deprecation-contracts)) = v3.5.0
+Provides: bundled(php-composer(symfony/deprecation-contracts)) = v3.5.1
Provides: bundled(php-composer(symfony/event-dispatcher)) = v6.4.13
-Provides: bundled(php-composer(symfony/event-dispatcher-contracts)) = v3.5.0
+Provides: bundled(php-composer(symfony/event-dispatcher-contracts)) = v3.5.1
Provides: bundled(php-composer(symfony/filesystem)) = v6.4.13
Provides: bundled(php-composer(symfony/finder)) = v6.4.13
-Provides: bundled(php-composer(symfony/options-resolver)) = v6.4.13
+Provides: bundled(php-composer(symfony/options-resolver)) = v6.4.16
Provides: bundled(php-composer(symfony/polyfill-ctype)) = v1.31.0
Provides: bundled(php-composer(symfony/polyfill-intl-grapheme)) = v1.31.0
Provides: bundled(php-composer(symfony/polyfill-intl-normalizer)) = v1.31.0
@@ -83,11 +90,12 @@ Provides: bundled(php-composer(symfony/polyfill-mbstring)) = v1.31.0
Provides: bundled(php-composer(symfony/polyfill-php80)) = v1.31.0
Provides: bundled(php-composer(symfony/polyfill-php81)) = v1.31.0
Provides: bundled(php-composer(symfony/process)) = v6.4.15
-Provides: bundled(php-composer(symfony/service-contracts)) = v3.5.0
+Provides: bundled(php-composer(symfony/service-contracts)) = v3.5.1
Provides: bundled(php-composer(symfony/stopwatch)) = v6.4.13
Provides: bundled(php-composer(symfony/string)) = v6.4.15
Provides: php-composer(friendsofphp/php-cs-fixer) = %{version}
+%endif
%description
@@ -108,6 +116,7 @@ projects. This tool does not only detect them, but also fixes them for you.
%setup -q -n %{gh_project}-%{gh_commit}
%patch -P0 -p1 -b .rpm
+%if %{without generators}
: List bundled libraries and Licenses
php -r '
$pkgs = file_get_contents("vendor/composer/installed.json");
@@ -128,6 +137,7 @@ php -r '
printf("# License %s\n%s\n", $lic, implode("\n", $lib));
}
'
+%endif
%build
# Empty build section, most likely nothing required.
@@ -158,6 +168,10 @@ PHP_CS_FIXER_IGNORE_ENV=1 ./%{name} --version | grep %{version}
%changelog
+* Mon Dec 30 2024 Remi Collet <remi@remirepo.net> - 3.66.0-1
+- update to 3.66.0
+- add option to use composer-generators
+
* Mon Nov 25 2024 Remi Collet <remi@remirepo.net> - 3.65.0-1
- update to 3.65.0