summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json6
-rw-r--r--installed.json40
-rw-r--r--php-cs-fixer.spec15
3 files changed, 37 insertions, 24 deletions
diff --git a/composer.json b/composer.json
index f291eb3..f106058 100644
--- a/composer.json
+++ b/composer.json
@@ -74,7 +74,10 @@
"autoload-dev": {
"psr-4": {
"PhpCsFixer\\Tests\\": "tests/"
- }
+ },
+ "exclude-from-classmap": [
+ "tests/Fixtures/"
+ ]
},
"bin": [
"php-cs-fixer"
@@ -124,6 +127,7 @@
"self-check": [
"./dev-tools/check_file_permissions.sh",
"./dev-tools/check_trailing_spaces.sh",
+ "@composer dump-autoload --dry-run --optimize --strict-psr",
"@normalize",
"@unused-deps",
"@require-checker",
diff --git a/installed.json b/installed.json
index 978844b..53e85bd 100644
--- a/installed.json
+++ b/installed.json
@@ -69,32 +69,40 @@
},
{
"name": "composer/pcre",
- "version": "3.1.4",
- "version_normalized": "3.1.4.0",
+ "version": "3.2.0",
+ "version_normalized": "3.2.0.0",
"source": {
"type": "git",
"url": "https://github.com/composer/pcre.git",
- "reference": "04229f163664973f68f38f6f73d917799168ef24"
+ "reference": "ea4ab6f9580a4fd221e0418f2c357cdd39102a90"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/composer/pcre/zipball/04229f163664973f68f38f6f73d917799168ef24",
- "reference": "04229f163664973f68f38f6f73d917799168ef24",
+ "url": "https://api.github.com/repos/composer/pcre/zipball/ea4ab6f9580a4fd221e0418f2c357cdd39102a90",
+ "reference": "ea4ab6f9580a4fd221e0418f2c357cdd39102a90",
"shasum": ""
},
"require": {
"php": "^7.4 || ^8.0"
},
+ "conflict": {
+ "phpstan/phpstan": "<1.11.8"
+ },
"require-dev": {
- "phpstan/phpstan": "^1.3",
+ "phpstan/phpstan": "^1.11.8",
"phpstan/phpstan-strict-rules": "^1.1",
- "symfony/phpunit-bridge": "^5"
+ "phpunit/phpunit": "^8 || ^9"
},
- "time": "2024-05-27T13:40:54+00:00",
+ "time": "2024-07-25T09:36:02+00:00",
"type": "library",
"extra": {
"branch-alias": {
"dev-main": "3.x-dev"
+ },
+ "phpstan": {
+ "includes": [
+ "extension.neon"
+ ]
}
},
"installation-source": "dist",
@@ -123,7 +131,7 @@
],
"support": {
"issues": "https://github.com/composer/pcre/issues",
- "source": "https://github.com/composer/pcre/tree/3.1.4"
+ "source": "https://github.com/composer/pcre/tree/3.2.0"
},
"funding": [
{
@@ -143,17 +151,17 @@
},
{
"name": "composer/semver",
- "version": "3.4.0",
- "version_normalized": "3.4.0.0",
+ "version": "3.4.2",
+ "version_normalized": "3.4.2.0",
"source": {
"type": "git",
"url": "https://github.com/composer/semver.git",
- "reference": "35e8d0af4486141bc745f23a29cc2091eb624a32"
+ "reference": "c51258e759afdb17f1fd1fe83bc12baaef6309d6"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/composer/semver/zipball/35e8d0af4486141bc745f23a29cc2091eb624a32",
- "reference": "35e8d0af4486141bc745f23a29cc2091eb624a32",
+ "url": "https://api.github.com/repos/composer/semver/zipball/c51258e759afdb17f1fd1fe83bc12baaef6309d6",
+ "reference": "c51258e759afdb17f1fd1fe83bc12baaef6309d6",
"shasum": ""
},
"require": {
@@ -163,7 +171,7 @@
"phpstan/phpstan": "^1.4",
"symfony/phpunit-bridge": "^4.2 || ^5"
},
- "time": "2023-08-31T09:50:34+00:00",
+ "time": "2024-07-12T11:35:52+00:00",
"type": "library",
"extra": {
"branch-alias": {
@@ -207,7 +215,7 @@
"support": {
"irc": "ircs://irc.libera.chat:6697/composer",
"issues": "https://github.com/composer/semver/issues",
- "source": "https://github.com/composer/semver/tree/3.4.0"
+ "source": "https://github.com/composer/semver/tree/3.4.2"
},
"funding": [
{
diff --git a/php-cs-fixer.spec b/php-cs-fixer.spec
index d1b12e3..2cdae8b 100644
--- a/php-cs-fixer.spec
+++ b/php-cs-fixer.spec
@@ -10,14 +10,14 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 30ba9ecc2b0e5205e578fe29973c15653d9bfd29
+%global gh_commit e595e4e070d17c5d42ed8c4206f630fcc5f401a4
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_date 2024-06-16
+%global gh_date 2024-07-25
%global gh_owner FriendsOfPHP
%global gh_project PHP-CS-Fixer
Name: php-cs-fixer
-Version: 3.59.3
+Version: 3.60.0
Release: 1%{?dist}
Summary: PHP Coding Standards Fixer
@@ -54,8 +54,8 @@ Provides: php-cs-fixer3 = %{version}
Provides: bundled(php-sebastian-diff) = 5.1.1
# License MIT
Provides: bundled(php-clue-ndjson-react) = v1.3.0
-Provides: bundled(php-composer-pcre) = 3.1.4
-Provides: bundled(php-composer-semver) = 3.4.0
+Provides: bundled(php-composer-pcre) = 3.2.0
+Provides: bundled(php-composer-semver) = 3.4.2
Provides: bundled(php-composer-xdebug-handler) = 3.0.5
Provides: bundled(php-evenement-evenement) = v3.0.2
Provides: bundled(php-fidry-cpu-core-counter) = 1.1.0
@@ -149,8 +149,6 @@ PHP_CS_FIXER_IGNORE_ENV=1 ./%{name} --version | grep %{version}
%files
-# remirepo:1
-%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc composer.json
%doc vendor/composer/installed.json
@@ -160,6 +158,9 @@ PHP_CS_FIXER_IGNORE_ENV=1 ./%{name} --version | grep %{version}
%changelog
+* Thu Jul 25 2024 Remi Collet <remi@remirepo.net> - 3.60.0-1
+- update to 3.60.0
+
* Tue Jul 2 2024 Remi Collet <remi@remirepo.net> - 3.59.3-1
- update to 3.59.3