summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json15
-rw-r--r--installed.json238
-rw-r--r--php-cs-fixer.spec41
3 files changed, 151 insertions, 143 deletions
diff --git a/composer.json b/composer.json
index e0c8b6d..f291eb3 100644
--- a/composer.json
+++ b/composer.json
@@ -46,16 +46,16 @@
"symfony/stopwatch": "^5.4 || ^6.0 || ^7.0"
},
"require-dev": {
- "facile-it/paraunit": "^1.3 || ^2.0",
- "infection/infection": "^0.27.11",
+ "facile-it/paraunit": "^1.3 || ^2.3",
+ "infection/infection": "^0.29.5",
"justinrainbow/json-schema": "^5.2",
"keradus/cli-executor": "^2.1",
"mikey179/vfsstream": "^1.6.11",
"php-coveralls/php-coveralls": "^2.7",
"php-cs-fixer/accessible-object": "^1.1",
- "php-cs-fixer/phpunit-constraint-isidenticalstring": "^1.4",
- "php-cs-fixer/phpunit-constraint-xmlmatchesxsd": "^1.4",
- "phpunit/phpunit": "^9.6 || ^10.5.5 || ^11.0.2",
+ "php-cs-fixer/phpunit-constraint-isidenticalstring": "^1.5",
+ "php-cs-fixer/phpunit-constraint-xmlmatchesxsd": "^1.5",
+ "phpunit/phpunit": "^9.6.19 || ^10.5.21 || ^11.2",
"symfony/var-dumper": "^5.4 || ^6.0 || ^7.0",
"symfony/yaml": "^5.4 || ^6.0 || ^7.0"
},
@@ -66,7 +66,10 @@
"autoload": {
"psr-4": {
"PhpCsFixer\\": "src/"
- }
+ },
+ "exclude-from-classmap": [
+ "src/Fixer/Internal/*"
+ ]
},
"autoload-dev": {
"psr-4": {
diff --git a/installed.json b/installed.json
index 58112fa..978844b 100644
--- a/installed.json
+++ b/installed.json
@@ -729,31 +729,31 @@
},
{
"name": "react/dns",
- "version": "v1.12.0",
- "version_normalized": "1.12.0.0",
+ "version": "v1.13.0",
+ "version_normalized": "1.13.0.0",
"source": {
"type": "git",
"url": "https://github.com/reactphp/dns.git",
- "reference": "c134600642fa615b46b41237ef243daa65bb64ec"
+ "reference": "eb8ae001b5a455665c89c1df97f6fb682f8fb0f5"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/reactphp/dns/zipball/c134600642fa615b46b41237ef243daa65bb64ec",
- "reference": "c134600642fa615b46b41237ef243daa65bb64ec",
+ "url": "https://api.github.com/repos/reactphp/dns/zipball/eb8ae001b5a455665c89c1df97f6fb682f8fb0f5",
+ "reference": "eb8ae001b5a455665c89c1df97f6fb682f8fb0f5",
"shasum": ""
},
"require": {
"php": ">=5.3.0",
"react/cache": "^1.0 || ^0.6 || ^0.5",
"react/event-loop": "^1.2",
- "react/promise": "^3.0 || ^2.7 || ^1.2.1"
+ "react/promise": "^3.2 || ^2.7 || ^1.2.1"
},
"require-dev": {
"phpunit/phpunit": "^9.6 || ^5.7 || ^4.8.36",
- "react/async": "^4 || ^3 || ^2",
- "react/promise-timer": "^1.9"
+ "react/async": "^4.3 || ^3 || ^2",
+ "react/promise-timer": "^1.11"
},
- "time": "2023-11-29T12:41:06+00:00",
+ "time": "2024-06-13T14:18:03+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -796,7 +796,7 @@
],
"support": {
"issues": "https://github.com/reactphp/dns/issues",
- "source": "https://github.com/reactphp/dns/tree/v1.12.0"
+ "source": "https://github.com/reactphp/dns/tree/v1.13.0"
},
"funding": [
{
@@ -1042,17 +1042,17 @@
},
{
"name": "react/stream",
- "version": "v1.3.0",
- "version_normalized": "1.3.0.0",
+ "version": "v1.4.0",
+ "version_normalized": "1.4.0.0",
"source": {
"type": "git",
"url": "https://github.com/reactphp/stream.git",
- "reference": "6fbc9672905c7d5a885f2da2fc696f65840f4a66"
+ "reference": "1e5b0acb8fe55143b5b426817155190eb6f5b18d"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/reactphp/stream/zipball/6fbc9672905c7d5a885f2da2fc696f65840f4a66",
- "reference": "6fbc9672905c7d5a885f2da2fc696f65840f4a66",
+ "url": "https://api.github.com/repos/reactphp/stream/zipball/1e5b0acb8fe55143b5b426817155190eb6f5b18d",
+ "reference": "1e5b0acb8fe55143b5b426817155190eb6f5b18d",
"shasum": ""
},
"require": {
@@ -1062,9 +1062,9 @@
},
"require-dev": {
"clue/stream-filter": "~1.2",
- "phpunit/phpunit": "^9.5 || ^5.7 || ^4.8.35"
+ "phpunit/phpunit": "^9.6 || ^5.7 || ^4.8.36"
},
- "time": "2023-06-16T10:52:11+00:00",
+ "time": "2024-06-11T12:45:25+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1111,7 +1111,7 @@
],
"support": {
"issues": "https://github.com/reactphp/stream/issues",
- "source": "https://github.com/reactphp/stream/tree/v1.3.0"
+ "source": "https://github.com/reactphp/stream/tree/v1.4.0"
},
"funding": [
{
@@ -1193,17 +1193,17 @@
},
{
"name": "symfony/console",
- "version": "v6.4.7",
- "version_normalized": "6.4.7.0",
+ "version": "v6.4.9",
+ "version_normalized": "6.4.9.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/console.git",
- "reference": "a170e64ae10d00ba89e2acbb590dc2e54da8ad8f"
+ "reference": "6edb5363ec0c78ad4d48c5128ebf4d083d89d3a9"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/console/zipball/a170e64ae10d00ba89e2acbb590dc2e54da8ad8f",
- "reference": "a170e64ae10d00ba89e2acbb590dc2e54da8ad8f",
+ "url": "https://api.github.com/repos/symfony/console/zipball/6edb5363ec0c78ad4d48c5128ebf4d083d89d3a9",
+ "reference": "6edb5363ec0c78ad4d48c5128ebf4d083d89d3a9",
"shasum": ""
},
"require": {
@@ -1236,7 +1236,7 @@
"symfony/stopwatch": "^5.4|^6.0|^7.0",
"symfony/var-dumper": "^5.4|^6.0|^7.0"
},
- "time": "2024-04-18T09:22:46+00:00",
+ "time": "2024-06-28T09:49:33+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1270,7 +1270,7 @@
"terminal"
],
"support": {
- "source": "https://github.com/symfony/console/tree/v6.4.7"
+ "source": "https://github.com/symfony/console/tree/v6.4.9"
},
"funding": [
{
@@ -1360,17 +1360,17 @@
},
{
"name": "symfony/event-dispatcher",
- "version": "v6.4.7",
- "version_normalized": "6.4.7.0",
+ "version": "v6.4.8",
+ "version_normalized": "6.4.8.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/event-dispatcher.git",
- "reference": "d84384f3f67de3cb650db64d685d70395dacfc3f"
+ "reference": "8d7507f02b06e06815e56bb39aa0128e3806208b"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/event-dispatcher/zipball/d84384f3f67de3cb650db64d685d70395dacfc3f",
- "reference": "d84384f3f67de3cb650db64d685d70395dacfc3f",
+ "url": "https://api.github.com/repos/symfony/event-dispatcher/zipball/8d7507f02b06e06815e56bb39aa0128e3806208b",
+ "reference": "8d7507f02b06e06815e56bb39aa0128e3806208b",
"shasum": ""
},
"require": {
@@ -1395,7 +1395,7 @@
"symfony/service-contracts": "^2.5|^3",
"symfony/stopwatch": "^5.4|^6.0|^7.0"
},
- "time": "2024-04-18T09:22:46+00:00",
+ "time": "2024-05-31T14:49:08+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1423,7 +1423,7 @@
"description": "Provides tools that allow your application components to communicate with each other by dispatching events and listening to them",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/event-dispatcher/tree/v6.4.7"
+ "source": "https://github.com/symfony/event-dispatcher/tree/v6.4.8"
},
"funding": [
{
@@ -1522,26 +1522,28 @@
},
{
"name": "symfony/filesystem",
- "version": "v6.4.7",
- "version_normalized": "6.4.7.0",
+ "version": "v6.4.9",
+ "version_normalized": "6.4.9.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/filesystem.git",
- "reference": "78dde75f8f6dbbca4ec436a4b0087f7af02076d4"
+ "reference": "b51ef8059159330b74a4d52f68e671033c0fe463"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/filesystem/zipball/78dde75f8f6dbbca4ec436a4b0087f7af02076d4",
- "reference": "78dde75f8f6dbbca4ec436a4b0087f7af02076d4",
+ "url": "https://api.github.com/repos/symfony/filesystem/zipball/b51ef8059159330b74a4d52f68e671033c0fe463",
+ "reference": "b51ef8059159330b74a4d52f68e671033c0fe463",
"shasum": ""
},
"require": {
"php": ">=8.1",
"symfony/polyfill-ctype": "~1.8",
- "symfony/polyfill-mbstring": "~1.8",
- "symfony/process": "^5.4|^6.4"
+ "symfony/polyfill-mbstring": "~1.8"
+ },
+ "require-dev": {
+ "symfony/process": "^5.4|^6.4|^7.0"
},
- "time": "2024-04-18T09:22:46+00:00",
+ "time": "2024-06-28T09:49:33+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1569,7 +1571,7 @@
"description": "Provides basic utilities for the filesystem",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/filesystem/tree/v6.4.7"
+ "source": "https://github.com/symfony/filesystem/tree/v6.4.9"
},
"funding": [
{
@@ -1589,17 +1591,17 @@
},
{
"name": "symfony/finder",
- "version": "v6.4.7",
- "version_normalized": "6.4.7.0",
+ "version": "v6.4.8",
+ "version_normalized": "6.4.8.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/finder.git",
- "reference": "511c48990be17358c23bf45c5d71ab85d40fb764"
+ "reference": "3ef977a43883215d560a2cecb82ec8e62131471c"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/finder/zipball/511c48990be17358c23bf45c5d71ab85d40fb764",
- "reference": "511c48990be17358c23bf45c5d71ab85d40fb764",
+ "url": "https://api.github.com/repos/symfony/finder/zipball/3ef977a43883215d560a2cecb82ec8e62131471c",
+ "reference": "3ef977a43883215d560a2cecb82ec8e62131471c",
"shasum": ""
},
"require": {
@@ -1608,7 +1610,7 @@
"require-dev": {
"symfony/filesystem": "^6.0|^7.0"
},
- "time": "2024-04-23T10:36:43+00:00",
+ "time": "2024-05-31T14:49:08+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1636,7 +1638,7 @@
"description": "Finds files and directories via an intuitive fluent interface",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/finder/tree/v6.4.7"
+ "source": "https://github.com/symfony/finder/tree/v6.4.8"
},
"funding": [
{
@@ -1656,24 +1658,24 @@
},
{
"name": "symfony/options-resolver",
- "version": "v6.4.7",
- "version_normalized": "6.4.7.0",
+ "version": "v6.4.8",
+ "version_normalized": "6.4.8.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/options-resolver.git",
- "reference": "9a3c92b490716ba6771f5beced13c6eda7183eed"
+ "reference": "22ab9e9101ab18de37839074f8a1197f55590c1b"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/options-resolver/zipball/9a3c92b490716ba6771f5beced13c6eda7183eed",
- "reference": "9a3c92b490716ba6771f5beced13c6eda7183eed",
+ "url": "https://api.github.com/repos/symfony/options-resolver/zipball/22ab9e9101ab18de37839074f8a1197f55590c1b",
+ "reference": "22ab9e9101ab18de37839074f8a1197f55590c1b",
"shasum": ""
},
"require": {
"php": ">=8.1",
"symfony/deprecation-contracts": "^2.5|^3"
},
- "time": "2024-04-18T09:22:46+00:00",
+ "time": "2024-05-31T14:49:08+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1706,7 +1708,7 @@
"options"
],
"support": {
- "source": "https://github.com/symfony/options-resolver/tree/v6.4.7"
+ "source": "https://github.com/symfony/options-resolver/tree/v6.4.8"
},
"funding": [
{
@@ -1726,17 +1728,17 @@
},
{
"name": "symfony/polyfill-ctype",
- "version": "v1.29.0",
- "version_normalized": "1.29.0.0",
+ "version": "v1.30.0",
+ "version_normalized": "1.30.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-ctype.git",
- "reference": "ef4d7e442ca910c4764bce785146269b30cb5fc4"
+ "reference": "0424dff1c58f028c451efff2045f5d92410bd540"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/polyfill-ctype/zipball/ef4d7e442ca910c4764bce785146269b30cb5fc4",
- "reference": "ef4d7e442ca910c4764bce785146269b30cb5fc4",
+ "url": "https://api.github.com/repos/symfony/polyfill-ctype/zipball/0424dff1c58f028c451efff2045f5d92410bd540",
+ "reference": "0424dff1c58f028c451efff2045f5d92410bd540",
"shasum": ""
},
"require": {
@@ -1748,7 +1750,7 @@
"suggest": {
"ext-ctype": "For best performance"
},
- "time": "2024-01-29T20:11:03+00:00",
+ "time": "2024-05-31T15:07:36+00:00",
"type": "library",
"extra": {
"thanks": {
@@ -1788,7 +1790,7 @@
"portable"
],
"support": {
- "source": "https://github.com/symfony/polyfill-ctype/tree/v1.29.0"
+ "source": "https://github.com/symfony/polyfill-ctype/tree/v1.30.0"
},
"funding": [
{
@@ -1808,17 +1810,17 @@
},
{
"name": "symfony/polyfill-intl-grapheme",
- "version": "v1.29.0",
- "version_normalized": "1.29.0.0",
+ "version": "v1.30.0",
+ "version_normalized": "1.30.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-intl-grapheme.git",
- "reference": "32a9da87d7b3245e09ac426c83d334ae9f06f80f"
+ "reference": "64647a7c30b2283f5d49b874d84a18fc22054b7a"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/polyfill-intl-grapheme/zipball/32a9da87d7b3245e09ac426c83d334ae9f06f80f",
- "reference": "32a9da87d7b3245e09ac426c83d334ae9f06f80f",
+ "url": "https://api.github.com/repos/symfony/polyfill-intl-grapheme/zipball/64647a7c30b2283f5d49b874d84a18fc22054b7a",
+ "reference": "64647a7c30b2283f5d49b874d84a18fc22054b7a",
"shasum": ""
},
"require": {
@@ -1827,7 +1829,7 @@
"suggest": {
"ext-intl": "For best performance"
},
- "time": "2024-01-29T20:11:03+00:00",
+ "time": "2024-05-31T15:07:36+00:00",
"type": "library",
"extra": {
"thanks": {
@@ -1869,7 +1871,7 @@
"shim"
],
"support": {
- "source": "https://github.com/symfony/polyfill-intl-grapheme/tree/v1.29.0"
+ "source": "https://github.com/symfony/polyfill-intl-grapheme/tree/v1.30.0"
},
"funding": [
{
@@ -1889,17 +1891,17 @@
},
{
"name": "symfony/polyfill-intl-normalizer",
- "version": "v1.29.0",
- "version_normalized": "1.29.0.0",
+ "version": "v1.30.0",
+ "version_normalized": "1.30.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-intl-normalizer.git",
- "reference": "bc45c394692b948b4d383a08d7753968bed9a83d"
+ "reference": "a95281b0be0d9ab48050ebd988b967875cdb9fdb"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/polyfill-intl-normalizer/zipball/bc45c394692b948b4d383a08d7753968bed9a83d",
- "reference": "bc45c394692b948b4d383a08d7753968bed9a83d",
+ "url": "https://api.github.com/repos/symfony/polyfill-intl-normalizer/zipball/a95281b0be0d9ab48050ebd988b967875cdb9fdb",
+ "reference": "a95281b0be0d9ab48050ebd988b967875cdb9fdb",
"shasum": ""
},
"require": {
@@ -1908,7 +1910,7 @@
"suggest": {
"ext-intl": "For best performance"
},
- "time": "2024-01-29T20:11:03+00:00",
+ "time": "2024-05-31T15:07:36+00:00",
"type": "library",
"extra": {
"thanks": {
@@ -1953,7 +1955,7 @@
"shim"
],
"support": {
- "source": "https://github.com/symfony/polyfill-intl-normalizer/tree/v1.29.0"
+ "source": "https://github.com/symfony/polyfill-intl-normalizer/tree/v1.30.0"
},
"funding": [
{
@@ -1973,17 +1975,17 @@
},
{
"name": "symfony/polyfill-mbstring",
- "version": "v1.29.0",
- "version_normalized": "1.29.0.0",
+ "version": "v1.30.0",
+ "version_normalized": "1.30.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-mbstring.git",
- "reference": "9773676c8a1bb1f8d4340a62efe641cf76eda7ec"
+ "reference": "fd22ab50000ef01661e2a31d850ebaa297f8e03c"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/polyfill-mbstring/zipball/9773676c8a1bb1f8d4340a62efe641cf76eda7ec",
- "reference": "9773676c8a1bb1f8d4340a62efe641cf76eda7ec",
+ "url": "https://api.github.com/repos/symfony/polyfill-mbstring/zipball/fd22ab50000ef01661e2a31d850ebaa297f8e03c",
+ "reference": "fd22ab50000ef01661e2a31d850ebaa297f8e03c",
"shasum": ""
},
"require": {
@@ -1995,7 +1997,7 @@
"suggest": {
"ext-mbstring": "For best performance"
},
- "time": "2024-01-29T20:11:03+00:00",
+ "time": "2024-06-19T12:30:46+00:00",
"type": "library",
"extra": {
"thanks": {
@@ -2036,7 +2038,7 @@
"shim"
],
"support": {
- "source": "https://github.com/symfony/polyfill-mbstring/tree/v1.29.0"
+ "source": "https://github.com/symfony/polyfill-mbstring/tree/v1.30.0"
},
"funding": [
{
@@ -2056,23 +2058,23 @@
},
{
"name": "symfony/polyfill-php80",
- "version": "v1.29.0",
- "version_normalized": "1.29.0.0",
+ "version": "v1.30.0",
+ "version_normalized": "1.30.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-php80.git",
- "reference": "87b68208d5c1188808dd7839ee1e6c8ec3b02f1b"
+ "reference": "77fa7995ac1b21ab60769b7323d600a991a90433"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/polyfill-php80/zipball/87b68208d5c1188808dd7839ee1e6c8ec3b02f1b",
- "reference": "87b68208d5c1188808dd7839ee1e6c8ec3b02f1b",
+ "url": "https://api.github.com/repos/symfony/polyfill-php80/zipball/77fa7995ac1b21ab60769b7323d600a991a90433",
+ "reference": "77fa7995ac1b21ab60769b7323d600a991a90433",
"shasum": ""
},
"require": {
"php": ">=7.1"
},
- "time": "2024-01-29T20:11:03+00:00",
+ "time": "2024-05-31T15:07:36+00:00",
"type": "library",
"extra": {
"thanks": {
@@ -2119,7 +2121,7 @@
"shim"
],
"support": {
- "source": "https://github.com/symfony/polyfill-php80/tree/v1.29.0"
+ "source": "https://github.com/symfony/polyfill-php80/tree/v1.30.0"
},
"funding": [
{
@@ -2139,23 +2141,23 @@
},
{
"name": "symfony/polyfill-php81",
- "version": "v1.29.0",
- "version_normalized": "1.29.0.0",
+ "version": "v1.30.0",
+ "version_normalized": "1.30.0.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/polyfill-php81.git",
- "reference": "c565ad1e63f30e7477fc40738343c62b40bc672d"
+ "reference": "3fb075789fb91f9ad9af537c4012d523085bd5af"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/polyfill-php81/zipball/c565ad1e63f30e7477fc40738343c62b40bc672d",
- "reference": "c565ad1e63f30e7477fc40738343c62b40bc672d",
+ "url": "https://api.github.com/repos/symfony/polyfill-php81/zipball/3fb075789fb91f9ad9af537c4012d523085bd5af",
+ "reference": "3fb075789fb91f9ad9af537c4012d523085bd5af",
"shasum": ""
},
"require": {
"php": ">=7.1"
},
- "time": "2024-01-29T20:11:03+00:00",
+ "time": "2024-06-19T12:30:46+00:00",
"type": "library",
"extra": {
"thanks": {
@@ -2198,7 +2200,7 @@
"shim"
],
"support": {
- "source": "https://github.com/symfony/polyfill-php81/tree/v1.29.0"
+ "source": "https://github.com/symfony/polyfill-php81/tree/v1.30.0"
},
"funding": [
{
@@ -2218,23 +2220,23 @@
},
{
"name": "symfony/process",
- "version": "v6.4.7",
- "version_normalized": "6.4.7.0",
+ "version": "v6.4.8",
+ "version_normalized": "6.4.8.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/process.git",
- "reference": "cdb1c81c145fd5aa9b0038bab694035020943381"
+ "reference": "8d92dd79149f29e89ee0f480254db595f6a6a2c5"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/process/zipball/cdb1c81c145fd5aa9b0038bab694035020943381",
- "reference": "cdb1c81c145fd5aa9b0038bab694035020943381",
+ "url": "https://api.github.com/repos/symfony/process/zipball/8d92dd79149f29e89ee0f480254db595f6a6a2c5",
+ "reference": "8d92dd79149f29e89ee0f480254db595f6a6a2c5",
"shasum": ""
},
"require": {
"php": ">=8.1"
},
- "time": "2024-04-18T09:22:46+00:00",
+ "time": "2024-05-31T14:49:08+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -2262,7 +2264,7 @@
"description": "Executes commands in sub-processes",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/process/tree/v6.4.7"
+ "source": "https://github.com/symfony/process/tree/v6.4.8"
},
"funding": [
{
@@ -2368,24 +2370,24 @@
},
{
"name": "symfony/stopwatch",
- "version": "v6.4.7",
- "version_normalized": "6.4.7.0",
+ "version": "v6.4.8",
+ "version_normalized": "6.4.8.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/stopwatch.git",
- "reference": "ffec95ba269e541eb2232126c0c20f83086b5c68"
+ "reference": "63e069eb616049632cde9674c46957819454b8aa"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/stopwatch/zipball/ffec95ba269e541eb2232126c0c20f83086b5c68",
- "reference": "ffec95ba269e541eb2232126c0c20f83086b5c68",
+ "url": "https://api.github.com/repos/symfony/stopwatch/zipball/63e069eb616049632cde9674c46957819454b8aa",
+ "reference": "63e069eb616049632cde9674c46957819454b8aa",
"shasum": ""
},
"require": {
"php": ">=8.1",
"symfony/service-contracts": "^2.5|^3"
},
- "time": "2024-04-18T09:22:46+00:00",
+ "time": "2024-05-31T14:49:08+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -2413,7 +2415,7 @@
"description": "Provides a way to profile code",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/stopwatch/tree/v6.4.7"
+ "source": "https://github.com/symfony/stopwatch/tree/v6.4.8"
},
"funding": [
{
@@ -2433,17 +2435,17 @@
},
{
"name": "symfony/string",
- "version": "v6.4.7",
- "version_normalized": "6.4.7.0",
+ "version": "v6.4.9",
+ "version_normalized": "6.4.9.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/string.git",
- "reference": "ffeb9591c61f65a68d47f77d12b83fa530227a69"
+ "reference": "76792dbd99690a5ebef8050d9206c60c59e681d7"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/string/zipball/ffeb9591c61f65a68d47f77d12b83fa530227a69",
- "reference": "ffeb9591c61f65a68d47f77d12b83fa530227a69",
+ "url": "https://api.github.com/repos/symfony/string/zipball/76792dbd99690a5ebef8050d9206c60c59e681d7",
+ "reference": "76792dbd99690a5ebef8050d9206c60c59e681d7",
"shasum": ""
},
"require": {
@@ -2463,7 +2465,7 @@
"symfony/translation-contracts": "^2.5|^3.0",
"symfony/var-exporter": "^5.4|^6.0|^7.0"
},
- "time": "2024-04-18T09:22:46+00:00",
+ "time": "2024-06-28T09:25:38+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -2502,7 +2504,7 @@
"utf8"
],
"support": {
- "source": "https://github.com/symfony/string/tree/v6.4.7"
+ "source": "https://github.com/symfony/string/tree/v6.4.9"
},
"funding": [
{
diff --git a/php-cs-fixer.spec b/php-cs-fixer.spec
index a636389..d1b12e3 100644
--- a/php-cs-fixer.spec
+++ b/php-cs-fixer.spec
@@ -10,14 +10,14 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 04e9424025677a86914b9a4944dbbf4060bb0aff
+%global gh_commit 30ba9ecc2b0e5205e578fe29973c15653d9bfd29
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_date 2024-05-29
+%global gh_date 2024-06-16
%global gh_owner FriendsOfPHP
%global gh_project PHP-CS-Fixer
Name: php-cs-fixer
-Version: 3.58.1
+Version: 3.59.3
Release: 1%{?dist}
Summary: PHP Coding Standards Fixer
@@ -64,28 +64,28 @@ Provides: bundled(php-psr-event-dispatcher) = 1.0.0
Provides: bundled(php-psr-log) = 2.0.0
Provides: bundled(php-react-cache) = v1.2.0
Provides: bundled(php-react-child-process) = v0.6.5
-Provides: bundled(php-react-dns) = v1.12.0
+Provides: bundled(php-react-dns) = v1.13.0
Provides: bundled(php-react-event-loop) = v1.5.0
Provides: bundled(php-react-promise) = v3.2.0
Provides: bundled(php-react-socket) = v1.15.0
-Provides: bundled(php-react-stream) = v1.3.0
-Provides: bundled(php-symfony-console) = v6.4.7
+Provides: bundled(php-react-stream) = v1.4.0
+Provides: bundled(php-symfony-console) = v6.4.9
Provides: bundled(php-symfony-deprecation-contracts) = v3.5.0
-Provides: bundled(php-symfony-event-dispatcher) = v6.4.7
+Provides: bundled(php-symfony-event-dispatcher) = v6.4.8
Provides: bundled(php-symfony-event-dispatcher-contracts) = v3.5.0
-Provides: bundled(php-symfony-filesystem) = v6.4.7
-Provides: bundled(php-symfony-finder) = v6.4.7
-Provides: bundled(php-symfony-options-resolver) = v6.4.7
-Provides: bundled(php-symfony-polyfill-ctype) = v1.29.0
-Provides: bundled(php-symfony-polyfill-intl-grapheme) = v1.29.0
-Provides: bundled(php-symfony-polyfill-intl-normalizer) = v1.29.0
-Provides: bundled(php-symfony-polyfill-mbstring) = v1.29.0
-Provides: bundled(php-symfony-polyfill-php80) = v1.29.0
-Provides: bundled(php-symfony-polyfill-php81) = v1.29.0
-Provides: bundled(php-symfony-process) = v6.4.7
+Provides: bundled(php-symfony-filesystem) = v6.4.9
+Provides: bundled(php-symfony-finder) = v6.4.8
+Provides: bundled(php-symfony-options-resolver) = v6.4.8
+Provides: bundled(php-symfony-polyfill-ctype) = v1.30.0
+Provides: bundled(php-symfony-polyfill-intl-grapheme) = v1.30.0
+Provides: bundled(php-symfony-polyfill-intl-normalizer) = v1.30.0
+Provides: bundled(php-symfony-polyfill-mbstring) = v1.30.0
+Provides: bundled(php-symfony-polyfill-php80) = v1.30.0
+Provides: bundled(php-symfony-polyfill-php81) = v1.30.0
+Provides: bundled(php-symfony-process) = v6.4.8
Provides: bundled(php-symfony-service-contracts) = v3.5.0
-Provides: bundled(php-symfony-stopwatch) = v6.4.7
-Provides: bundled(php-symfony-string) = v6.4.7
+Provides: bundled(php-symfony-stopwatch) = v6.4.8
+Provides: bundled(php-symfony-string) = v6.4.9
Provides: php-composer(friendsofphp/php-cs-fixer) = %{version}
@@ -160,6 +160,9 @@ PHP_CS_FIXER_IGNORE_ENV=1 ./%{name} --version | grep %{version}
%changelog
+* Tue Jul 2 2024 Remi Collet <remi@remirepo.net> - 3.59.3-1
+- update to 3.59.3
+
* Thu May 30 2024 Remi Collet <remi@remirepo.net> - 3.58.1-1
- update to 3.58.1