summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json2
-rw-r--r--php-cs-fixer.spec9
2 files changed, 8 insertions, 3 deletions
diff --git a/composer.json b/composer.json
index 772c867..a3f667e 100644
--- a/composer.json
+++ b/composer.json
@@ -117,6 +117,7 @@
"@composer normalize --working-dir=dev-tools ../composer.json",
"@composer normalize --working-dir=dev-tools composer.json"
],
+ "php-compatibility": "@php dev-tools/vendor/bin/phpcs -p --standard=dev-tools/php-compatibility/phpcs-php-compatibility.xml",
"phpstan": "@php -d memory_limit=512M dev-tools/vendor/bin/phpstan analyse",
"phpstan:baseline": "@php -d memory_limit=512M dev-tools/vendor/bin/phpstan analyse --generate-baseline=./dev-tools/phpstan/baseline.php",
"qa": "@quality-assurance",
@@ -185,6 +186,7 @@
"mess-detector": "Analyse code with Mess Detector",
"normalize": "Check normalization for composer.json files",
"normalize:fix": "Run normalization for composer.json files",
+ "php-compatibility": "Check compatibility with all supported PHP versions",
"phpstan": "Run PHPStan analysis",
"phpstan:baseline": "Dump PHPStan baseline file - use only for updating, do not add new errors when possible",
"post-autoload-dump": "Run additional tasks after installing/updating main dependencies",
diff --git a/php-cs-fixer.spec b/php-cs-fixer.spec
index 68f506f..13ad108 100644
--- a/php-cs-fixer.spec
+++ b/php-cs-fixer.spec
@@ -13,14 +13,14 @@
%bcond_with generators
-%global gh_commit 0ad34c75d1172f7d30320460e803887981830cbf
+%global gh_commit db533e9aeb19c33033b6a1b734c8de4f4ebaa7dc
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_date 2025-01-08
+%global gh_date 2025-01-12
%global gh_owner FriendsOfPHP
%global gh_project PHP-CS-Fixer
Name: php-cs-fixer
-Version: 3.67.0
+Version: 3.67.1
Release: 1%{?dist}
Summary: PHP Coding Standards Fixer
@@ -168,6 +168,9 @@ PHP_CS_FIXER_IGNORE_ENV=1 ./%{name} --version | grep %{version}
%changelog
+* Mon Jan 13 2025 Remi Collet <remi@remirepo.net> - 3.67.1-1
+- update to 3.67.1
+
* Wed Jan 8 2025 Remi Collet <remi@remirepo.net> - 3.67.0-1
- update to 3.67.0