summaryrefslogtreecommitdiffstats
path: root/php-pecl-zip.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-zip.spec')
-rw-r--r--php-pecl-zip.spec19
1 files changed, 8 insertions, 11 deletions
diff --git a/php-pecl-zip.spec b/php-pecl-zip.spec
index 1baab90..ff14a81 100644
--- a/php-pecl-zip.spec
+++ b/php-pecl-zip.spec
@@ -12,7 +12,6 @@
%{?scl:%scl_package php-pecl-zip}
-
%if ( 0%{?scl:1} && 0%{?rhel} == 8 ) || 0%{?rhel} >= 9
%bcond_without move_to_opt
%else
@@ -21,16 +20,16 @@
%bcond_without tests
-%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
-%global pecl_name zip
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
+%global pecl_name zip
-%global upstream_version 1.22.3
+%global upstream_version 1.22.4
#global upstream_prever dev
#global upstream_lower DEV
%global sources %{pecl_name}-%{upstream_version}%{?upstream_prever}
%global _configure ../%{sources}/configure
-%global libzip_version 1.10.1
+%global libzip_version 1.11.1
%if "%{php_version}" < "5.6"
%global ini_name %{pecl_name}.ini
@@ -42,14 +41,12 @@
Summary: A ZIP archive management extension
Name: %{?scl_prefix}php-pecl-zip
Version: %{upstream_version}%{?upstream_prever:~%{upstream_lower}}
-Release: 5%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP-3.01
Group: Development/Languages
URL: https://pecl.php.net/package/zip
Source0: https://pecl.php.net/get/%{sources}.tgz
-Patch0: upstream.patch
-Patch1: zip-php84.patch
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
@@ -97,9 +94,6 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd %{sources}
-%patch -P0 -p1
-%patch -P1 -p1
-
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_ZIP_VERSION/{s/.* "//;s/".*$//;p}' php7/php_zip.h)
if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}" -a "x${extver}" != "x%{upstream_version}-%{?upstream_prever}"; then
@@ -223,6 +217,9 @@ TEST_PHP_EXECUTABLE=%{__ztsphp} \
%changelog
+* Thu Sep 26 2024 Remi Collet <remi@remirepo.net> - 1.22.4-1
+- update to 1.22.4
+
* Tue Sep 24 2024 Remi Collet <remi@remirepo.net> - 1.22.3-5
- rebuild for 8.4.0RC1