summaryrefslogtreecommitdiffstats
path: root/php-pecl-protobuf.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-protobuf.spec')
-rw-r--r--php-pecl-protobuf.spec18
1 files changed, 11 insertions, 7 deletions
diff --git a/php-pecl-protobuf.spec b/php-pecl-protobuf.spec
index 8cd0575..809dc9a 100644
--- a/php-pecl-protobuf.spec
+++ b/php-pecl-protobuf.spec
@@ -12,7 +12,7 @@
%global pecl_name protobuf
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global ini_name 40-%{pecl_name}.ini
-%global upstream_version 4.28.1
+%global upstream_version 4.28.2
#global upstream_prever RC3
%global sources %{pecl_name}-%{upstream_version}%{?upstream_prever}
%global _configure ../%{sources}/configure
@@ -89,19 +89,20 @@ EOF
cd %{sources}
%{__phpize}
+sed -e 's/INSTALL_ROOT/DESTDIR/' -i build/Makefile.global
cd ../NTS
%configure \
--enable-protobuf \
--with-php-config=%{__phpconfig}
-make %{?_smp_mflags}
+%make_build
%if %{with_zts}
cd ../ZTS
%configure \
--enable-protobuf \
--with-php-config=%{__ztsphpconfig}
-make %{?_smp_mflags}
+%make_build
%endif
@@ -109,12 +110,12 @@ make %{?_smp_mflags}
%{?dtsenable}
# Install the NTS stuff
-make -C NTS install INSTALL_ROOT=%{buildroot}
+%make_install -C NTS
install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
%if %{with_zts}
# Install the ZTS stuff
-make -C ZTS install INSTALL_ROOT=%{buildroot}
+%make_install -C ZTS
install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
@@ -135,13 +136,13 @@ done
: Minimal load test for NTS extension
%{__php} --no-php-ini \
--define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
- --modules | grep %{pecl_name}
+ --modules | grep '^%{pecl_name}$'
%if %{with_zts}
: Minimal load test for ZTS extension
%{__ztsphp} --no-php-ini \
--define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
- --modules | grep %{pecl_name}
+ --modules | grep '^%{pecl_name}$'
%endif
@@ -160,6 +161,9 @@ done
%changelog
+* Thu Sep 19 2024 Remi Collet <remi@remirepo.net> - 4.28.2-1
+- update to 4.28.2 (no change)
+
* Thu Sep 12 2024 Remi Collet <remi@remirepo.net> - 4.28.1-1
- update to 4.28.1