summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION4
-rw-r--r--pcov-php84.patch25
-rw-r--r--php-pecl-pcov.spec12
4 files changed, 9 insertions, 34 deletions
diff --git a/PHPINFO b/PHPINFO
index 2980007..46ebfc2 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
pcov
PCOV support => Disabled
-PCOV version => 1.0.11
+PCOV version => 1.0.12
pcov.directory => auto
pcov.exclude => none
pcov.initial.memory => 65336 bytes
diff --git a/REFLECTION b/REFLECTION
index 11e0352..6103f7b 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #89 pcov version 1.0.11 ] {
+Extension [ <persistent> extension #128 pcov version 1.0.12 ] {
- Dependencies {
Dependency [ pcre (Required) ]
@@ -26,7 +26,7 @@ Extension [ <persistent> extension #89 pcov version 1.0.11 ] {
Constant [ int pcov\all ] { 0 }
Constant [ int pcov\inclusive ] { 1 }
Constant [ int pcov\exclusive ] { 2 }
- Constant [ string pcov\version ] { 1.0.11 }
+ Constant [ string pcov\version ] { 1.0.12 }
}
- Functions {
diff --git a/pcov-php84.patch b/pcov-php84.patch
deleted file mode 100644
index 238c7bf..0000000
--- a/pcov-php84.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 7d764c7c2555e8287351961d72be3ebec4d8743f Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Fri, 12 Jul 2024 10:18:53 +0200
-Subject: [PATCH] Fix php_pcre_match_impl with 8.4
-
----
- pcov.c | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/pcov.c b/pcov.c
-index f04ba9c..4f7d158 100644
---- a/pcov.c
-+++ b/pcov.c
-@@ -137,7 +137,11 @@ static zend_always_inline zend_bool php_pcov_wants(zend_string *filename) { /* {
- ZSTR_VAL(filename), ZSTR_LEN(filename),
- #endif
- &match, NULL,
-+#if PHP_VERSION_ID >= 80400
-+ false, 0, 0);
-+#else
- 0, 0, 0, 0);
-+#endif
-
- if (zend_is_true(&match)) {
- zend_hash_add_empty_element(
diff --git a/php-pecl-pcov.spec b/php-pecl-pcov.spec
index a0abff5..8dd8ea7 100644
--- a/php-pecl-pcov.spec
+++ b/php-pecl-pcov.spec
@@ -16,14 +16,12 @@
Summary: Code coverage driver
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 1.0.11
-Release: 5%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 1.0.12
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP-3.01
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{sources}.tgz
-Patch0: %{pecl_name}-php84.patch
-
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 7.1
@@ -53,8 +51,6 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd %{sources}
-%patch -P0 -p1
-
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_PCOV_VERSION/{s/.* "//;s/".*$//;p}' php_pcov.h)
if test "x${extver}" != "x%{version}%{?prever:-%{prever}}"; then
@@ -180,6 +176,10 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Wed Dec 4 2024 Remi Collet <remi@remirepo.net> - 1.0.12-1
+- update to 1.0.12
+- drop patch merged upstream
+
* Tue Sep 24 2024 Remi Collet <remi@remirepo.net> - 1.0.11-5
- rebuild for 8.4.0RC1