summaryrefslogtreecommitdiffstats
path: root/php-pecl-mongodb.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-mongodb.spec')
-rw-r--r--php-pecl-mongodb.spec22
1 files changed, 14 insertions, 8 deletions
diff --git a/php-pecl-mongodb.spec b/php-pecl-mongodb.spec
index e86a5cb..9b976aa 100644
--- a/php-pecl-mongodb.spec
+++ b/php-pecl-mongodb.spec
@@ -31,16 +31,16 @@
%endif
# Bundled versions
-%global bundled_libmongo 1.28.1
-%global bundled_libcrypt 1.11.0
+%global bundled_libmongo 1.30.1
+%global bundled_libcrypt 1.12.0
# Required versions (in config.m4)
-%global minimal_libmongo 1.28.1
-%global minimal_libcrypt 1.11.0
+%global minimal_libmongo 1.30.1
+%global minimal_libcrypt 1.12.0
%if %{with syslib}
# Build dependencies (in repository)
-%global system_libmongo 1.28.1
-%global system_libcrypt 1.11.0
+%global system_libmongo 1.30
+%global system_libcrypt 1.12
# Runtime dependencies
%global runtime_libmongo %(pkg-config --silence-errors --modversion libmongoc-1.0 2>/dev/null || echo %{system_libmongo})
%global runtime_libcrypt %(pkg-config --silence-errors --modversion libmongocrypt 2>/dev/null || echo %{system_libcrypt})
@@ -48,7 +48,7 @@
Summary: MongoDB driver for PHP
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-%global upstream_version 1.20.1
+%global upstream_version 1.21.0
#global upstream_prever beta1
#global upstream_lower ~beta1
%global sources %{pecl_name}-%{upstream_version}%{?upstream_prever}
@@ -65,7 +65,7 @@ Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upst
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
-BuildRequires: %{?scl_prefix}php-devel >= 7.4
+BuildRequires: %{?scl_prefix}php-devel >= 8.1
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-json
%if %{with syslib}
@@ -309,6 +309,12 @@ exit $ret
%changelog
+* Fri Feb 28 2025 Remi Collet <remi@remirepo.net> - 1.21.0-1
+- update to 1.21.0
+- raise dependency on PHP 8.1
+- raise dependency on libbson and libmongc 1.30
+- raise dependency on libmongocrypt 1.12
+
* Wed Nov 27 2024 Remi Collet <remi@remirepo.net> - 1.20.1-1
- update to 1.20.1