summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION99
-rw-r--r--php-pecl-krb5.spec19
3 files changed, 110 insertions, 12 deletions
diff --git a/PHPINFO b/PHPINFO
index f76f707..0020bbc 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,8 +2,8 @@
krb5
Kerberos 5 support => enabled
-Extension version => 1.1.5
-Library version => Kerberos 5 release 1.19.2
+Extension version => 1.2.1
+Library version => Kerberos 5 release 1.21.2
KADM5 support => yes
Import cred support => no
GSSAPI/SPNEGO auth support => yes
diff --git a/REFLECTION b/REFLECTION
index 3c0fea3..9f8d360 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #79 krb5 version 1.1.5 ] {
+Extension [ <persistent> extension #79 krb5 version 1.2.1 ] {
- Constants [14] {
Constant [ int GSS_C_DELEG_FLAG ] { 1 }
@@ -17,7 +17,7 @@ Extension [ <persistent> extension #79 krb5 version 1.1.5 ] {
Constant [ int KRB5_TL_DB_ARGS ] { 32767 }
}
- - Classes [7] {
+ - Classes [8] {
Class [ <internal:krb5> class KRB5CCache ] {
- Constants [0] {
@@ -676,7 +676,7 @@ Extension [ <persistent> extension #79 krb5 version 1.1.5 ] {
Method [ <internal:krb5> public method initSecContext ] {
- - Parameters [7] {
+ - Parameters [8] {
Parameter #0 [ <required> $target ]
Parameter #1 [ <optional> $input_token = <default> ]
Parameter #2 [ <optional> $reqflags = <default> ]
@@ -684,18 +684,20 @@ Extension [ <persistent> extension #79 krb5 version 1.1.5 ] {
Parameter #4 [ <optional> &$output_token = <default> ]
Parameter #5 [ <optional> &$ret_flags = <default> ]
Parameter #6 [ <optional> &$time_rec = <default> ]
+ Parameter #7 [ <optional> GSSAPIChannelBinding &$channel = <default> ]
}
}
Method [ <internal:krb5> public method acceptSecContext ] {
- - Parameters [6] {
+ - Parameters [7] {
Parameter #0 [ <required> $input_token ]
Parameter #1 [ <optional> &$output_token = <default> ]
Parameter #2 [ <optional> &$src_name = <default> ]
Parameter #3 [ <optional> &$ret_flags = <default> ]
Parameter #4 [ <optional> &$time_rec = <default> ]
- Parameter #5 [ <optional> KRB5CCache $deleg = <default> ]
+ Parameter #5 [ <optional> ?KRB5CCache $deleg = <default> ]
+ Parameter #6 [ <optional> GSSAPIChannelBinding &$channel = <default> ]
}
}
@@ -739,7 +741,7 @@ Extension [ <persistent> extension #79 krb5 version 1.1.5 ] {
}
}
- Class [ <internal:krb5> class KRB5NegotiateAuth ] {
+ Class [ <internal:krb5> class GSSAPIChannelBinding ] {
- Constants [0] {
}
@@ -753,12 +755,89 @@ Extension [ <persistent> extension #79 krb5 version 1.1.5 ] {
- Properties [0] {
}
- - Methods [4] {
+ - Methods [9] {
Method [ <internal:krb5, ctor> public method __construct ] {
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:krb5> public method getInitiatorAddress ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:krb5> public method getInitiatorAddressType ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:krb5> public method setInitiatorAddress ] {
+
- Parameters [2] {
+ Parameter #0 [ <optional> $type = <default> ]
+ Parameter #1 [ <optional> $data = <default> ]
+ }
+ }
+
+ Method [ <internal:krb5> public method getAcceptorAddress ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:krb5> public method getAcceptorAddressType ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:krb5> public method setAcceptorAddress ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <optional> $type = <default> ]
+ Parameter #1 [ <optional> $data = <default> ]
+ }
+ }
+
+ Method [ <internal:krb5> public method getApplicationData ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:krb5> public method setApplicationData ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $data = <default> ]
+ }
+ }
+ }
+ }
+
+ Class [ <internal:krb5> class KRB5NegotiateAuth ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [5] {
+ Method [ <internal:krb5, ctor> public method __construct ] {
+
+ - Parameters [3] {
Parameter #0 [ <required> $keytab ]
Parameter #1 [ <optional> $spn = <default> ]
+ Parameter #2 [ <optional> ?GSSAPIChannelBinding $channel = <default> ]
}
}
@@ -780,6 +859,12 @@ Extension [ <persistent> extension #79 krb5 version 1.1.5 ] {
- Parameters [0] {
}
}
+
+ Method [ <internal:krb5> public method isChannelBound ] {
+
+ - Parameters [0] {
+ }
+ }
}
}
}
diff --git a/php-pecl-krb5.spec b/php-pecl-krb5.spec
index 896c2b3..5a8e2ec 100644
--- a/php-pecl-krb5.spec
+++ b/php-pecl-krb5.spec
@@ -3,7 +3,7 @@
#
# Fedora spec file for php-pecl-krb5
#
-# Copyright (c) 2014-2023 Remi Collet
+# Copyright (c) 2014-2024 Remi Collet
# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -35,11 +35,12 @@
Summary: Kerberos authentification extension
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 1.1.5
-Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 1.2.1
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: MIT
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+Source1: https://raw.githubusercontent.com/php/pecl-authentication-krb5/krb5-%{version}/channel.c
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
@@ -47,6 +48,10 @@ BuildRequires: krb5-devel >= 1.8
BuildRequires: pkgconfig(com_err)
BuildRequires: %{?scl_prefix}php-devel
BuildRequires: %{?scl_prefix}php-pear
+%if 0%{?fedora} >= 40
+# TODO need investigation
+BuildRequires: gmp
+%endif
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
@@ -91,6 +96,7 @@ These are the files needed to compile programs using the Kerberos extension.
%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
cd %{sources}
+cp %{SOURCE1} .
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_KRB5_VERSION/{s/.* "//;s/".*$//;p}' php_krb5.h)
if test "x${extver}" != "x%{version}"; then
@@ -221,6 +227,13 @@ fi
%changelog
+* Mon Jun 10 2024 Remi Collet <remi@remirepo.net> - 1.2.1-1
+- update to 1.2.1
+- fix missing channel.c in sources
+ https://github.com/php/pecl-authentication-krb5/pull/5
+- drop support for PHP 5
+ https://github.com/php/pecl-authentication-krb5/issues/6
+
* Wed Aug 30 2023 Remi Collet <remi@remirepo.net> - 1.1.5-3
- rebuild for PHP 8.3.0RC1