summaryrefslogtreecommitdiffstats
path: root/php-pecl-ev.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2024-09-03 16:12:41 +0200
committerRemi Collet <remi@php.net>2024-09-03 16:12:41 +0200
commit40e721e5d9a20de79a845df411526b2b139d1682 (patch)
tree5a880d96e05dad9e022e33c25ed2779db75fbf56 /php-pecl-ev.spec
parentb3fd561776586fd46343f33c9c72110287257904 (diff)
update to 1.2.0
Diffstat (limited to 'php-pecl-ev.spec')
-rw-r--r--php-pecl-ev.spec61
1 files changed, 13 insertions, 48 deletions
diff --git a/php-pecl-ev.spec b/php-pecl-ev.spec
index e719282..f838e85 100644
--- a/php-pecl-ev.spec
+++ b/php-pecl-ev.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-ev
#
-# Copyright (c) 2013-2023 Remi Collet
+# Copyright (c) 2013-2024 Remi Collet
# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -15,15 +15,10 @@
%global pecl_name ev
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
-%if "%{php_version}" < "5.6"
-# After sockets
-%global ini_name z-%{pecl_name}.ini
-%else
# After 20-sockets
%global ini_name 40-%{pecl_name}.ini
-%endif
-%global upstream_version 1.1.6
-%global upstream_prever RC1
+%global upstream_version 1.2.0
+#global upstream_prever RC1
#global upstream_postver r1
%global sources %{pecl_name}-%{upstream_version}%{?upstream_prever}%{?upstream_postver}
%global _configure ../%{sources}/configure
@@ -31,14 +26,14 @@
Summary: Provides interface to libev library
Name: %{?scl_prefix}php-pecl-%{pecl_name}
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}%{?upstream_postver:+%{upstream_postver}}
-Release: 2%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
-License: PHP
+Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+License: PHP-3.01
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{sources}.tgz
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
-BuildRequires: %{?scl_prefix}php-devel
+BuildRequires: %{?scl_prefix}php-devel >= 8.0
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-sockets
# For tests
@@ -66,12 +61,12 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
# Don't register test files on install
sed -e 's/role="test"/role="src"/' \
- %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
+ -e '/LICENSE/s/role="doc"/role="src"/' \
-i package.xml
cd %{sources}
# Sanity check, really often broken
-extver=$(sed -n '/define PHP_EV_VERSION/{s/.* "//;s/".*$//;p}' php%(%{__php} -r 'echo PHP_MAJOR_VERSION;')/php_ev.h)
+extver=$(sed -n '/define PHP_EV_VERSION/{s/.* "//;s/".*$//;p}' php_ev.h)
if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}%{?upstream_postver}"; then
: Error: Upstream extension version is ${extver}, expecting %{upstream_version}%{?upstream_prever}%{?upstream_postver}.
exit 1
@@ -137,32 +132,9 @@ do install -Dpm 644 $i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
-%if 0%{?fedora} < 24 && 0%{?rhel} < 8
-# when pear installed alone, after us
-%triggerin -- %{?scl_prefix}php-pear
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-# posttrans as pear can be installed after us
-%posttrans
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-%postun
-if [ $1 -eq 0 -a -x %{__pecl} ] ; then
- %{pecl_uninstall} %{pecl_name} >/dev/null || :
-fi
-%endif
-
-
%check
cd %{sources}
-# Erratic results
-rm tests/bug44-uncaught-exception.php5.phpt
-
DEPMOD="-n"
[ -f %{php_extdir}/sockets.so ] && DEPMOD="$DEPMOD -d extension=sockets.so"
[ -f %{php_extdir}/posix.so ] && DEPMOD="$DEPMOD -d extension=posix.so"
@@ -175,10 +147,8 @@ DEPMOD="-n"
%if %{with tests}
: Upstream test suite for NTS extension
-TEST_PHP_EXECUTABLE=%{__php} \
TEST_PHP_ARGS="$DEPMOD -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
-REPORT_EXIT_STATUS=1 \
-%{__php} -n run-tests.php -q --show-diff
+%{__php} -n run-tests.php -q --show-diff %{?_smp_mflags}
%endif
%if %{with_zts}
@@ -187,19 +157,11 @@ REPORT_EXIT_STATUS=1 \
$DEPMOD \
--define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
--modules | grep '^%{pecl_name}$'
-
-%if %{with tests}
-: Upstream test suite for ZTS extension
-TEST_PHP_EXECUTABLE=%{__ztsphp} \
-TEST_PHP_ARGS="$DEPMOD -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
-REPORT_EXIT_STATUS=1 \
-%{__ztsphp} -n run-tests.php -q --show-diff
-%endif
%endif
%files
-%{?_licensedir:%license %{sources}/LICENSE}
+%license %{sources}/LICENSE
%doc %{pecl_docdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
@@ -213,6 +175,9 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Tue Sep 3 2024 Remi Collet <remi@remirepo.net> - 1.2.0-1
+- update to 1.2.0
+
* Fri Sep 1 2023 Remi Collet <remi@remirepo.net> - 1.1.6~RC1-2
- build out of sources tree