summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json96
-rw-r--r--php-league-plates.spec31
2 files changed, 65 insertions, 62 deletions
diff --git a/composer.json b/composer.json
index 9845103..e39044a 100644
--- a/composer.json
+++ b/composer.json
@@ -1,52 +1,52 @@
{
- "name": "league/plates",
- "description": "Plates, the native PHP template system that's fast, easy to use and easy to extend.",
- "keywords": [
- "league",
- "package",
- "templating",
- "templates",
- "views"
- ],
- "homepage": "https://platesphp.com",
- "license": "MIT",
- "authors" : [
- {
- "name": "Jonathan Reinink",
- "email": "jonathan@reinink.ca",
- "role": "Developer"
- },
- {
- "name": "RJ Garcia",
- "email": "ragboyjr@icloud.com",
- "role": "Developer"
- }
- ],
- "require" : {
- "php": "^7.0|^8.0"
+ "name": "league/plates",
+ "description": "Plates, the native PHP template system that's fast, easy to use and easy to extend.",
+ "keywords": [
+ "league",
+ "package",
+ "templating",
+ "templates",
+ "views"
+ ],
+ "homepage": "https://platesphp.com",
+ "license": "MIT",
+ "authors": [
+ {
+ "name": "Jonathan Reinink",
+ "email": "jonathan@reinink.ca",
+ "role": "Developer"
},
- "require-dev": {
- "mikey179/vfsstream": "^1.6",
- "phpunit/phpunit": "^9.5",
- "squizlabs/php_codesniffer": "^3.5"
- },
- "autoload": {
- "psr-4": {
- "League\\Plates\\": "src"
- }
- },
- "autoload-dev": {
- "psr-4": {
- "League\\Plates\\Tests\\": "tests"
- }
- },
- "extra": {
- "branch-alias": {
- "dev-master": "3.0-dev"
- }
- },
- "scripts": {
- "test": "phpunit --testdox --colors=always",
- "docs": "hugo -s doc server"
+ {
+ "name": "RJ Garcia",
+ "email": "ragboyjr@icloud.com",
+ "role": "Developer"
+ }
+ ],
+ "require": {
+ "php": "^8.0"
+ },
+ "require-dev": {
+ "mikey179/vfsstream": "^1.6",
+ "phpunit/phpunit": "^11.4",
+ "squizlabs/php_codesniffer": "^3.5"
+ },
+ "autoload": {
+ "psr-4": {
+ "League\\Plates\\": "src"
+ }
+ },
+ "autoload-dev": {
+ "psr-4": {
+ "League\\Plates\\Tests\\": "tests"
+ }
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "3.0-dev"
}
+ },
+ "scripts": {
+ "test": "phpunit --testdox --colors=always",
+ "docs": "hugo -s doc server"
+ }
}
diff --git a/php-league-plates.spec b/php-league-plates.spec
index acb7edd..2dafa5d 100644
--- a/php-league-plates.spec
+++ b/php-league-plates.spec
@@ -1,13 +1,13 @@
# remirepo/fedora spec file for php-league-plates
#
-# Copyright (c) 2016-2023 Remi Collet
+# Copyright (c) 2016-2024 Remi Collet
# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
# Github
-%global gh_commit a6a3238e46c6e19af7318fdc36bfbe49b0620231
+%global gh_commit 12ee65166adbc6fb5916fb80b0c0758e49a2d996
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner thephpleague
%global gh_project plates
@@ -19,7 +19,7 @@
%global ns_project Plates
Name: php-%{pk_vendor}-%{pk_name}
-Version: 3.5.0
+Version: 3.6.0
Release: 1%{?dist}
Summary: Native PHP template system
@@ -31,23 +31,23 @@ Source0: %{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
BuildArch: noarch
-# as we use phpunit9
-BuildRequires: php(language) >= 7.3
+BuildRequires: php(language) >= 8.0
BuildRequires: php-pcre
BuildRequires: php-spl
# From composer.json, "require-dev": {
# "mikey179/vfsstream": "^1.6",
-# "phpunit/phpunit": "^9.5",
+# "phpunit/phpunit": "^11.4",
# "squizlabs/php_codesniffer": "^3.5"
BuildRequires: php-composer(mikey179/vfsStream) >= 1.6
-BuildRequires: phpunit9 >= 9.5
+# phpunit11 not yet available
+BuildRequires: phpunit10
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# From composer.json, "require": {
-# "php": "^7.0|^8.0"
-Requires: php(language) >= 7.0
-# From phpcompatifo report for 3.1.1
+# "php": "^8.0"
+Requires: php(language) >= 8.0
+# From phpcompatinfo report for 3.1.1
Requires: php-pcre
Requires: php-spl
# Autoloader
@@ -95,9 +95,9 @@ EOF
: Run upstream test suite
ret=0
-for cmd in php php80 php81 php82; do
+for cmd in php php81 php82 php83 php84; do
if which $cmd; then
- $cmd %{_bindir}/phpunit9 || ret=1
+ $cmd %{_bindir}/phpunit10 || ret=1
fi
done
exit $ret
@@ -105,8 +105,6 @@ exit $ret
%files
-# remirepo:1
-%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md
%doc composer.json
@@ -114,6 +112,11 @@ exit $ret
%changelog
+* Mon Nov 4 2024 Remi Collet <remi@remirepo.net> - 3.6.0-1
+- update to 3.6.0
+- switch to phpunit10
+- raise dependency on PHP 8.0
+
* Wed Jan 18 2023 Remi Collet <remi@remirepo.net> - 3.5.0-1
- update to 3.5.0