From e3d432c949cf80d2e08aa138f45c7755e5d5e944 Mon Sep 17 00:00:00 2001
From: Remi Collet <fedora@famillecollet.com>
Date: Mon, 17 Dec 2012 10:56:40 +0100
Subject: php-JsonSchema: backport

---
 Makefile            | 10 ++++++++++
 php-JsonSchema.spec | 13 +++++++++----
 2 files changed, 19 insertions(+), 4 deletions(-)
 create mode 100644 Makefile

diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..d095534
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,10 @@
+SRCDIR := $(shell pwd)
+NAME   := $(shell basename $(SRCDIR))
+INCL1  := $(shell php-config --includes)
+INCL2  := -I $(shell php-config --include-dir)/sapi/embed
+LIBS   := -lphp5 $(shell php-config --libs)
+
+include ../../common/Makefile
+
+tembed: tembed.c
+	gcc -Wall $(INCL1) $(INCL2) tembed.c $(LIBS) -o tembed
diff --git a/php-JsonSchema.spec b/php-JsonSchema.spec
index 4eb441f..9f1a17f 100644
--- a/php-JsonSchema.spec
+++ b/php-JsonSchema.spec
@@ -13,9 +13,10 @@ License:   BSD
 URL:       https://github.com/justinrainbow/%{github_name}
 Source0:   %{url}/archive/%{version}.tar.gz
 
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
 BuildArch: noarch
 # Test build requires
-BuildRequires: php-common >= %{php_min_ver}
+BuildRequires: php(language) >= %{php_min_ver}
 BuildRequires: php-pear(pear.phpunit.de/PHPUnit)
 # Test build requires: phpci
 BuildRequires:  php-ctype
@@ -23,16 +24,16 @@ BuildRequires:  php-curl
 BuildRequires:  php-json
 BuildRequires:  php-pcre
 BuildRequires:  php-spl
-%{?fedora:BuildRequires: php-filter}
+BuildRequires: php-filter
 
-Requires:  php-common >= %{php_min_ver}
+Requires:  php(language) >= %{php_min_ver}
 # phpci requires
 Requires:  php-ctype
 Requires:  php-curl
 Requires:  php-json
 Requires:  php-pcre
 Requires:  php-spl
-%{?fedora:Requires: php-filter}
+Requires:  php-filter
 
 %description
 A PHP implementation for validating JSON structures against a given schema.
@@ -72,11 +73,15 @@ cp -rp src/%{lib_name} %{buildroot}%{_datadir}/php/
 
 
 %files
+%defattr(-,root,root,-)
 %doc LICENSE README.md composer.json
 %{_datadir}/php/%{lib_name}
 
 
 %changelog
+* Mon Dec 17 2012 Remi Collet <remi@fedoraproject.org> - 1.2.2-2
+- backport for remi repo.
+
 * Sun Dec  9 2012 Shawn Iwinski <shawn.iwinski@gmail.com> 1.2.2-2
 - Fixed failing Mock/Koji builds
 - Removed "docs" directory from %%doc
-- 
cgit