From 8cd5ae41f233b1ed3b756886f1d7d1f7e276cb3a Mon Sep 17 00:00:00 2001
From: Remi Collet <remi@remirepo.net>
Date: Wed, 2 May 2018 14:35:14 +0200
Subject: import from Fedora

---
 composer.json              |  50 +++++++++++++++
 php-grasmash-expander.spec | 148 +++++++++++++++++++++++++++++++++++++++++++++
 2 files changed, 198 insertions(+)
 create mode 100644 composer.json
 create mode 100644 php-grasmash-expander.spec

diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..e1b692b
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,50 @@
+{
+    "name": "grasmash/expander",
+    "description": "Expands internal property references in PHP arrays file.",
+    "type": "library",
+    "require": {
+        "php": ">=5.4",
+        "dflydev/dot-access-data": "^1.1.0"
+    },
+    "license": "MIT",
+    "authors": [
+        {
+            "name": "Matthew Grasmick"
+        }
+    ],
+    "minimum-stability": "stable",
+    "autoload": {
+        "psr-4": {
+            "Grasmash\\Expander\\": "src/"
+        }
+    },
+    "require-dev": {
+        "phpunit/phpunit": "^4|^5.5.4",
+        "satooshi/php-coveralls": "^1.0.2|dev-master",
+        "greg-1-anderson/composer-test-scenarios": "^1",
+        "squizlabs/php_codesniffer": "^2.7"
+    },
+    "scripts": {
+        "cs": "phpcs -n --standard=PSR2 src tests --exclude=Generic.Files.LineLength",
+        "cbf": "phpcbf -n --standard=PSR2 src tests --exclude=Generic.Files.LineLength",
+        "unit": "phpunit",
+        "lint": [
+            "find src -name '*.php' -print0 | xargs -0 -n1 php -l",
+            "find tests -name '*.php' -print0 | xargs -0 -n1 php -l"
+        ],
+        "test": [
+            "@lint",
+            "@unit",
+            "@cs"
+        ]
+    },
+    "config": {
+        "optimize-autoloader": true,
+        "sort-packages": true
+    },
+    "extra": {
+        "branch-alias": {
+            "dev-master": "1.x-dev"
+        }
+    }
+}
diff --git a/php-grasmash-expander.spec b/php-grasmash-expander.spec
new file mode 100644
index 0000000..cc80056
--- /dev/null
+++ b/php-grasmash-expander.spec
@@ -0,0 +1,148 @@
+#
+# Fedora spec file for php-grasmash-expander
+#
+# Copyright (c) 2018 Shawn Iwinski <shawn@iwin.ski>
+#
+# License: MIT
+# http://opensource.org/licenses/MIT
+#
+# Please preserve changelog entries
+#
+
+%global github_owner     grasmash
+%global github_name      expander
+%global github_version   1.0.0
+%global github_commit    95d6037344a4be1dd5f8e0b0b2571a28c397578f
+
+%global composer_vendor  grasmash
+%global composer_project expander
+
+# "php": ">=5.4"
+%global php_min_ver 5.4
+# "dflydev/dot-access-data": "^1.1.0"
+%global dflydev_dot_access_data_min_ver 1.1.0
+%global dflydev_dot_access_data_max_ver 2.0
+
+# Build using "--without tests" to disable tests
+%global with_tests 0%{!?_without_tests:1}
+
+%{!?phpdir:  %global phpdir  %{_datadir}/php}
+
+Name:          php-%{composer_vendor}-%{composer_project}
+Version:       %{github_version}
+Release:       1%{?github_release}%{?dist}
+Summary:       Expands internal property references in PHP arrays file
+
+Group:         Development/Libraries
+License:       MIT
+URL:           https://github.com/%{github_owner}/%{github_name}
+Source0:       %{url}/archive/%{github_commit}/%{name}-%{github_version}-%{github_commit}.tar.gz
+
+BuildArch:     noarch
+# Tests
+%if %{with_tests}
+## composer.json
+BuildRequires: php(language) >= %{php_min_ver}
+BuildRequires: php-composer(phpunit/phpunit)
+BuildRequires: php-composer(psr/log)
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-composer(dflydev/dot-access-data) >= %{dflydev_dot_access_data_min_ver} with php-composer(dflydev/dot-access-data) < %{dflydev_dot_access_data_max_ver})
+%else
+BuildRequires: php-composer(dflydev/dot-access-data) >= %{dflydev_dot_access_data_min_ver}
+BuildRequires: php-composer(dflydev/dot-access-data) <  %{dflydev_dot_access_data_max_ver}
+%endif
+## phpcompatinfo for version 1.0.0
+BuildRequires: php-pcre
+## Autoloader
+BuildRequires: php-composer(fedora/autoloader)
+%endif
+
+# composer.json
+Requires:      php(language) >= %{php_min_ver}
+Requires:      php-composer(psr/log)
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires:      (php-composer(dflydev/dot-access-data) >= %{dflydev_dot_access_data_min_ver} with php-composer(dflydev/dot-access-data) < %{dflydev_dot_access_data_max_ver})
+%else
+Requires:      php-composer(dflydev/dot-access-data) >= %{dflydev_dot_access_data_min_ver}
+Requires:      php-composer(dflydev/dot-access-data) <  %{dflydev_dot_access_data_max_ver}
+%endif
+# phpcompatinfo for version 1.0.0
+Requires:      php-pcre
+# Autoloader
+Requires:      php-composer(fedora/autoloader)
+
+# Composer
+Provides:      php-composer(%{composer_vendor}/%{composer_project}) = %{version}
+
+%description
+This tool expands property references in PHP arrays. For example implementation,
+see Yaml Expander [1].
+
+Autoloader: %{phpdir}/Grasmash/Expander/autoload.php
+
+[1] https://github.com/grasmash/yaml-expander
+
+
+%prep
+%setup -qn %{github_name}-%{github_commit}
+
+
+%build
+: Create autoloader
+cat <<'AUTOLOAD' | tee src/autoload.php
+<?php
+/**
+ * Autoloader for %{name} and its' dependencies
+ * (created by %{name}-%{version}-%{release}).
+ */
+require_once '%{phpdir}/Fedora/Autoloader/autoload.php';
+
+\Fedora\Autoloader\Autoload::addPsr4('Grasmash\\Expander\\', __DIR__);
+
+\Fedora\Autoloader\Dependencies::required(array(
+    '%{phpdir}/Dflydev/DotAccessData/autoload.php',
+    '%{phpdir}/Psr/Log/autoload.php',
+));
+AUTOLOAD
+
+
+%install
+mkdir -p %{buildroot}%{phpdir}/Grasmash
+cp -rp src %{buildroot}%{phpdir}/Grasmash/Expander
+
+
+%check
+%if %{with_tests}
+: Create tests bootstrap
+cat <<'BOOTSTRAP' | tee bootstrap.php
+<?php
+require '%{buildroot}%{phpdir}/Grasmash/Expander/autoload.php';
+//\Fedora\Autoloader\Autoload::addPsr4('xxxxx\\Test\\', __DIR__.'/tests');
+BOOTSTRAP
+
+: Upstream tests
+RETURN_CODE=0
+PHPUNIT=$(which phpunit)
+for PHP_EXEC in php %{?rhel:php54 php55} php56 php70 php71 php72; do
+    if [ "php" == "$PHP_EXEC" ] || which $PHP_EXEC; then
+        $PHP_EXEC $PHPUNIT --verbose --bootstrap bootstrap.php || RETURN_CODE=1
+    fi
+done
+exit $RETURN_CODE
+%else
+: Tests skipped
+%endif
+
+
+%files
+%{!?_licensedir:%global license %%doc}
+%license LICENSE.md
+%doc README.md
+%doc composer.json
+%dir %{phpdir}/Grasmash
+     %{phpdir}/Grasmash/Expander
+
+
+%changelog
+* Sat Apr 21 2018 Shawn Iwinski <shawn@iwin.ski> - 1.0.0-1
+- Initial package
-- 
cgit