summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer-bash-completion2
-rw-r--r--composer.spec7
-rw-r--r--installed.json70
3 files changed, 41 insertions, 38 deletions
diff --git a/composer-bash-completion b/composer-bash-completion
index 68f0ea2..7a9b48d 100644
--- a/composer-bash-completion
+++ b/composer-bash-completion
@@ -25,7 +25,7 @@ _sf_composer() {
local cur prev words cword
_get_comp_words_by_ref -n := cur prev words cword
- local completecmd=("$sf_cmd" "_complete" "--no-interaction" "-sbash" "-c$cword" "-S2.8.1")
+ local completecmd=("$sf_cmd" "_complete" "--no-interaction" "-sbash" "-c$cword" "-S2.8.2")
for w in ${words[@]}; do
w=$(printf -- '%b' "$w")
# remove quotes from typed values
diff --git a/composer.spec b/composer.spec
index 76785dc..8d689f2 100644
--- a/composer.spec
+++ b/composer.spec
@@ -13,7 +13,7 @@
%bcond_with generators
-%global gh_commit e52b8672276cf436670cdd6bd5de4353740e83b2
+%global gh_commit 6e543d03187c882ea1c6ba43add2467754427803
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_branch 2.0-dev
%global gh_owner composer
@@ -21,7 +21,7 @@
%global api_version 2.6.0
%global run_version 2.2.2
-%global upstream_version 2.8.1
+%global upstream_version 2.8.2
#global upstream_prever RC1
#global upstream_lower rc1
@@ -266,6 +266,9 @@ done
%changelog
+* Wed Oct 30 2024 Remi Collet <remi@remirepo.net> - 2.8.2-1
+- update to 2.8.2
+
* Fri Oct 4 2024 Remi Collet <remi@remirepo.net> - 2.8.1-1
- update to 2.8.1
diff --git a/installed.json b/installed.json
index d5f10ad..aae34b3 100644
--- a/installed.json
+++ b/installed.json
@@ -977,17 +977,17 @@
},
{
"name": "symfony/console",
- "version": "v5.4.44",
- "version_normalized": "5.4.44.0",
+ "version": "v5.4.45",
+ "version_normalized": "5.4.45.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/console.git",
- "reference": "5b5a0aa66e3296e303e22490f90f521551835a83"
+ "reference": "108d436c2af470858bdaba3257baab3a74172017"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/console/zipball/5b5a0aa66e3296e303e22490f90f521551835a83",
- "reference": "5b5a0aa66e3296e303e22490f90f521551835a83",
+ "url": "https://api.github.com/repos/symfony/console/zipball/108d436c2af470858bdaba3257baab3a74172017",
+ "reference": "108d436c2af470858bdaba3257baab3a74172017",
"shasum": ""
},
"require": {
@@ -1025,7 +1025,7 @@
"symfony/lock": "",
"symfony/process": ""
},
- "time": "2024-09-20T07:56:40+00:00",
+ "time": "2024-10-08T07:27:17+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1059,7 +1059,7 @@
"terminal"
],
"support": {
- "source": "https://github.com/symfony/console/tree/v5.4.44"
+ "source": "https://github.com/symfony/console/tree/v5.4.45"
},
"funding": [
{
@@ -1149,17 +1149,17 @@
},
{
"name": "symfony/filesystem",
- "version": "v5.4.44",
- "version_normalized": "5.4.44.0",
+ "version": "v5.4.45",
+ "version_normalized": "5.4.45.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/filesystem.git",
- "reference": "76c3818964e9d32be3862c9318ae3ba9aa280ddc"
+ "reference": "57c8294ed37d4a055b77057827c67f9558c95c54"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/filesystem/zipball/76c3818964e9d32be3862c9318ae3ba9aa280ddc",
- "reference": "76c3818964e9d32be3862c9318ae3ba9aa280ddc",
+ "url": "https://api.github.com/repos/symfony/filesystem/zipball/57c8294ed37d4a055b77057827c67f9558c95c54",
+ "reference": "57c8294ed37d4a055b77057827c67f9558c95c54",
"shasum": ""
},
"require": {
@@ -1171,7 +1171,7 @@
"require-dev": {
"symfony/process": "^5.4|^6.4"
},
- "time": "2024-09-16T14:52:48+00:00",
+ "time": "2024-10-22T13:05:35+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1199,7 +1199,7 @@
"description": "Provides basic utilities for the filesystem",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/filesystem/tree/v5.4.44"
+ "source": "https://github.com/symfony/filesystem/tree/v5.4.45"
},
"funding": [
{
@@ -1219,17 +1219,17 @@
},
{
"name": "symfony/finder",
- "version": "v5.4.43",
- "version_normalized": "5.4.43.0",
+ "version": "v5.4.45",
+ "version_normalized": "5.4.45.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/finder.git",
- "reference": "ae25a9145a900764158d439653d5630191155ca0"
+ "reference": "63741784cd7b9967975eec610b256eed3ede022b"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/finder/zipball/ae25a9145a900764158d439653d5630191155ca0",
- "reference": "ae25a9145a900764158d439653d5630191155ca0",
+ "url": "https://api.github.com/repos/symfony/finder/zipball/63741784cd7b9967975eec610b256eed3ede022b",
+ "reference": "63741784cd7b9967975eec610b256eed3ede022b",
"shasum": ""
},
"require": {
@@ -1237,7 +1237,7 @@
"symfony/deprecation-contracts": "^2.1|^3",
"symfony/polyfill-php80": "^1.16"
},
- "time": "2024-08-13T14:03:51+00:00",
+ "time": "2024-09-28T13:32:08+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1265,7 +1265,7 @@
"description": "Finds files and directories via an intuitive fluent interface",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/finder/tree/v5.4.43"
+ "source": "https://github.com/symfony/finder/tree/v5.4.45"
},
"funding": [
{
@@ -1856,24 +1856,24 @@
},
{
"name": "symfony/process",
- "version": "v5.4.44",
- "version_normalized": "5.4.44.0",
+ "version": "v5.4.45",
+ "version_normalized": "5.4.45.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/process.git",
- "reference": "1b9fa82b5c62cd49da8c9e3952dd8531ada65096"
+ "reference": "95f3f19d0f8f06e4253c66a0828ddb69f8b8ede4"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/process/zipball/1b9fa82b5c62cd49da8c9e3952dd8531ada65096",
- "reference": "1b9fa82b5c62cd49da8c9e3952dd8531ada65096",
+ "url": "https://api.github.com/repos/symfony/process/zipball/95f3f19d0f8f06e4253c66a0828ddb69f8b8ede4",
+ "reference": "95f3f19d0f8f06e4253c66a0828ddb69f8b8ede4",
"shasum": ""
},
"require": {
"php": ">=7.2.5",
"symfony/polyfill-php80": "^1.16"
},
- "time": "2024-09-17T12:46:43+00:00",
+ "time": "2024-09-25T14:11:13+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1901,7 +1901,7 @@
"description": "Executes commands in sub-processes",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/process/tree/v5.4.44"
+ "source": "https://github.com/symfony/process/tree/v5.4.45"
},
"funding": [
{
@@ -2007,17 +2007,17 @@
},
{
"name": "symfony/string",
- "version": "v5.4.44",
- "version_normalized": "5.4.44.0",
+ "version": "v5.4.45",
+ "version_normalized": "5.4.45.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/string.git",
- "reference": "832caa16b6d9aac6bf11747315225f5aba384c24"
+ "reference": "7f6807add88b1e2635f3c6de5e1ace631ed7cad2"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/string/zipball/832caa16b6d9aac6bf11747315225f5aba384c24",
- "reference": "832caa16b6d9aac6bf11747315225f5aba384c24",
+ "url": "https://api.github.com/repos/symfony/string/zipball/7f6807add88b1e2635f3c6de5e1ace631ed7cad2",
+ "reference": "7f6807add88b1e2635f3c6de5e1ace631ed7cad2",
"shasum": ""
},
"require": {
@@ -2037,7 +2037,7 @@
"symfony/translation-contracts": "^1.1|^2",
"symfony/var-exporter": "^4.4|^5.0|^6.0"
},
- "time": "2024-09-20T07:56:40+00:00",
+ "time": "2024-09-25T14:11:13+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -2076,7 +2076,7 @@
"utf8"
],
"support": {
- "source": "https://github.com/symfony/string/tree/v5.4.44"
+ "source": "https://github.com/symfony/string/tree/v5.4.45"
},
"funding": [
{